Bug 736887 - Network manager disconnects every 10 minutes on Intel PRO/Wireless 2915ABG and 3945ABG (ipw2200)
Summary: Network manager disconnects every 10 minutes on Intel PRO/Wireless 2915ABG an...
Keywords:
Status: CLOSED DUPLICATE of bug 717186
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 00:31 UTC by Pavel Šimerda (pavlix)
Modified: 2012-01-12 17:56 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-10 12:38:48 UTC


Attachments (Terms of Use)
dmesg output just after disconnect (123.11 KB, text/plain)
2011-10-27 15:13 UTC, Pavel Šimerda (pavlix)
no flags Details

Description Pavel Šimerda (pavlix) 2011-09-09 00:31:25 UTC
I've seen similar bugs in redhat bugzilla and other places. But what is very special here is that according to the DHCP log, both connected clients are
reconnecting almost exactly every 10 minutes.

The most cited reason in similar bugs is problems with scanning while connected. An almost precise interval suggests a problem like this.

I'm trying with an updated Fedora 15. The same proble applied to the recent Fedora kernels but I really think I was using wireless without this problem some time ago.

Package versions:

kernel-2.6.40.4-5.fc15.x86_64
NetworkManager-0.8.9997-6.git20110721.fc15.x86_64
iwl3945-firmware-15.32.2.9-5.fc15.noarch

Network adapter:

04:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

Other tested adapters:

06:05.0 Network controller: Intel Corporation PRO/Wireless 2915ABG [Calexico2] Network Connection (rev 05)

Comment 1 Pavel Šimerda (pavlix) 2011-10-27 15:13:25 UTC
Created attachment 530509 [details]
dmesg output just after disconnect

Comment 2 Pavel Šimerda (pavlix) 2011-10-27 15:14:46 UTC
It's no longer exactly 10 minutes but rather random

Comment 3 Jirka Klimes 2011-11-01 14:26:54 UTC
There are driver/firmware errors:
ipw2200: Firmware error detected.  Restarting.
Some posts suggests removing/reinserting driver helps.

Try getting driver debug output and/or bisect the problem as described in the following links.

See also:
http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=800
https://bugzilla.redhat.com/show_bug.cgi?id=717186

Comment 4 Pavel Šimerda (pavlix) 2011-12-24 03:55:46 UTC
I tried at least on older kernels (down to kernel-2.6.38.8-35.fc15.i686) and older firmwares (down to ipw2200-firmware-3.0-11.noarch.rpm) with no success.

I cannot find a single kernel and/or firmware available as rpm for Fedora that works. There's no point in compiling kernels if I don't have at least one functional from a package to start with.

Comment 5 Jirka Klimes 2012-01-10 12:38:48 UTC
Does the removing and reinserting the module helps?

You could try to get debugging logs via
# modprobe ipw2200 debug=0x3fff
or
# modprobe ipw2200 debug=0x8003fff

and attach them to the bug 717186.

(Making this duplicate of bug 717186.)

*** This bug has been marked as a duplicate of bug 717186 ***

Comment 6 Pavel Šimerda (pavlix) 2012-01-12 17:56:14 UTC
“Does the removing and reinserting the module helps?”

Not at all, the same for rebooting.

“and attach them to the bug 717186.”

Thanks.


Note You need to log in before you can comment on or make changes to this bug.