Bug 73690 - gnome changes x bell settings
Summary: gnome changes x bell settings
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-session   
(Show other bugs)
Version: null
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-08 22:24 UTC by Gordon Messmer
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-08 22:24:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gordon Messmer 2002-09-08 22:24:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
In my .Xclients file, I set several X settings, including:
xset b off

GNOME, however, turns the X bell back on.  This is very irritating, as my
motherboard "beeps" through the sound card.  No volume setting affects this
(except main volume), and it can't be disabled.  The bell is very very LOUD.

Can GNOME please leave the X bell setting alone?  It will normally be on unless
specifically disabled, so there should be no reason to change the setting.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. add "xset b off" to .Xclients, before 'gnome-session'
2. start emacs
3. hold the down arrow.
	

Actual Results:  BEEP

Expected Results:  Nothing.  Nothing at all.

Additional info:

Comment 1 Havoc Pennington 2002-09-08 23:42:37 UTC
Go to Preferences->Keyboard and disable the bell. (If that doesn't work then
it's very much a bug.)

GNOME can't leave the bell alone because then you couldn't enable/disable it
from the GUI. If there's a GUI setting GNOME has to make the X server setting
reflect 
the value set in the GUI.


Note You need to log in before you can comment on or make changes to this bug.