Bug 736905 - Amarok 1.4.10 in EPEL-5 attempts to use amazon.com for cover art and this does not work
Summary: Amarok 1.4.10 in EPEL-5 attempts to use amazon.com for cover art and this doe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: amarok
Version: el5
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 03:35 UTC by Trevor Hemsley
Modified: 2012-08-27 17:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-27 17:03:55 UTC


Attachments (Terms of Use)

Description Trevor Hemsley 2011-09-09 03:35:19 UTC
Description of problem:
Cover Art does not download

Version-Release number of selected component (if applicable):
amarok-1.4.10-7.20090624svn.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Enable EPEL-5 repo 
2. yum install amarok
3. Go to Tools -> Cover Manager
4. Expect to see some cover art downloaded
  
Actual results:
Nothing happens. Using tcpdump I can see a bad request from amazon.com coming back.

Expected results:
Covers should be downloaded

Additional info:
The spec file from the source package contains a patch102 amarok-1.4.10-coverfetcher.patch but this is never applied during the build. Downloading the source RPM and rebuilding it with patch102 applied right after patch2 and 3 produces a version of amarok that goes to last.fm for its covers rather than to Amazon.

Comment 1 Trevor Hemsley 2011-09-09 03:42:48 UTC
Looks like bug 523071 was closed without testing to see if the problem was actually fixed - only half a fix was done! The patch was built but never applied.

Comment 2 Fedora Update System 2012-03-18 23:10:44 UTC
amarok-1.4.10-8.20090624svn.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/amarok-1.4.10-8.20090624svn.el5

Comment 3 Fedora Update System 2012-03-19 20:00:29 UTC
Package amarok-1.4.10-8.20090624svn.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing amarok-1.4.10-8.20090624svn.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0812/amarok-1.4.10-8.20090624svn.el5
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2012-08-27 17:03:55 UTC
amarok-1.4.10-8.20090624svn.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.