Bug 736921 - SELinux is preventing /sbin/setfiles from 'write' accesses on the chr_file /dev/null.
Summary: SELinux is preventing /sbin/setfiles from 'write' accesses on the chr_file /d...
Keywords:
Status: CLOSED DUPLICATE of bug 736924
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:f08ebd78f7b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 05:48 UTC by Renich Bon Ciric
Modified: 2011-09-09 07:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 07:51:49 UTC


Attachments (Terms of Use)

Description Renich Bon Ciric 2011-09-09 05:48:12 UTC
SELinux is preventing /sbin/setfiles from 'write' accesses on the chr_file /dev/null.

*****  Plugin restorecon (85.2 confidence) suggests  *************************

If you want to fix the label. 
/dev/null default label should be null_device_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /dev/null

*****  Plugin file (7.27 confidence) suggests  *******************************

If you think this is caused by a badly mislabeled machine.
Then you need to fully relabel.
Do
touch /.autorelabel; reboot

*****  Plugin file (7.27 confidence) suggests  *******************************

If you think this is caused by a badly mislabeled machine.
Then you need to fully relabel.
Do
touch /.autorelabel; reboot

*****  Plugin catchall (1.34 confidence) suggests  ***************************

If you believe that setfiles should be allowed write access on the null chr_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep restorecon /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

*****  Plugin leaks (1.34 confidence) suggests  ******************************

If you want to ignore setfiles trying to write access the null chr_file, because you believe it should not need this access.
Then you should report this as a bug.  
You can generate a local policy module to dontaudit this access.
Do
# grep /sbin/setfiles /var/log/audit/audit.log | audit2allow -D -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c102
                              3
Target Context                unconfined_u:object_r:file_t:s0
Target Objects                /dev/null [ chr_file ]
Source                        restorecon
Source Path                   /sbin/setfiles
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           policycoreutils-2.0.86-7.fc15
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-38.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 2.6.40.4-5.fc15.x86_64 #1 SMP
                              Tue Aug 30 14:38:32 UTC 2011 x86_64 x86_64
Alert Count                   2
First Seen                    Fri 09 Sep 2011 12:47:10 AM CDT
Last Seen                     Fri 09 Sep 2011 12:47:45 AM CDT
Local ID                      962e2125-3fe0-44c3-a764-e17e9b7f78bd

Raw Audit Messages
type=AVC msg=audit(1315547265.684:2425): avc:  denied  { write } for  pid=13368 comm="restorecon" path="/dev/null" dev=dm-3 ino=32 scontext=unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:file_t:s0 tclass=chr_file


type=SYSCALL msg=audit(1315547265.684:2425): arch=x86_64 syscall=execve success=yes exit=0 a0=fef100 a1=fe9780 a2=fe9a60 a3=7fff585a2b30 items=0 ppid=13353 pid=13368 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=1 comm=restorecon exe=/sbin/setfiles subj=unconfined_u:unconfined_r:setfiles_t:s0-s0:c0.c1023 key=(null)

Hash: restorecon,setfiles_t,file_t,chr_file,write

audit2allow

#============= setfiles_t ==============
allow setfiles_t file_t:chr_file write;

audit2allow -R

#============= setfiles_t ==============
allow setfiles_t file_t:chr_file write;

Comment 1 Miroslav Grepl 2011-09-09 07:51:49 UTC

*** This bug has been marked as a duplicate of bug 736924 ***


Note You need to log in before you can comment on or make changes to this bug.