Bug 736946 - %post scriptlet broken
Summary: %post scriptlet broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: BackupPC
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bernard Johnson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 744218 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 07:05 UTC by David Juran
Modified: 2011-10-12 21:57 UTC (History)
5 users (show)

Fixed In Version: BackupPC-3.2.1-6.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-08 17:59:35 UTC


Attachments (Terms of Use)

Description David Juran 2011-09-09 07:05:03 UTC
Description of problem:
When upgrading BackupPC, yum logged the following error:

1 /var/tmp/rpm-tmp.WVd0Xn: line 15: syntax error near unexpected token `fi'
2 /var/tmp/rpm-tmp.WVd0Xn: line 15: `fi'
3 warning: %postun(BackupPC-3.2.1-1.fc14.x86_64) scriptlet failed, exit status 2


Version-Release number of selected component (if applicable):
BackupPC-3.2.1-4.fc14.x86_64


Additional info:

I believe removing the last if statement, i.e.

if [ $1 -ge 1 ]; then
  # Package upgrade, not uninstall
fi

solves the problem

Comment 1 Richard Marko 2011-09-09 15:08:59 UTC
Same for BackupPC-3.2.1-1.fc15.x86_64

(changing version to f15)

Comment 2 Branko Grubić 2011-09-12 12:50:31 UTC
I think I got the same error during the update
System: Fedora 15 (x86_64)

Part of yum output: 
Cleanup    : BackupPC-3.2.1-1.fc15.x86_64                                                80/86 
Non-fatal POSTUN scriptlet failure in rpm package BackupPC
  Cleanup    : gtkhtml3-4.0.1-1.fc15.x86_64                                                                                     81/86 
/var/tmp/rpm-tmp.afknv9: line 15: syntax error near unexpected token `fi'
/var/tmp/rpm-tmp.afknv9: line 15: `fi'
warning: %postun(BackupPC-3.2.1-1.fc15.x86_64) scriptlet failed, exit status 2

Comment 3 Bernard Johnson 2011-09-20 03:02:04 UTC
Note that since this is a %postun bug, you will see it again with the replacement package upgrade, but no more thereafter.

Comment 4 Fedora Update System 2011-09-26 23:04:24 UTC
BackupPC-3.2.1-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/BackupPC-3.2.1-6.fc16

Comment 5 Fedora Update System 2011-09-26 23:05:14 UTC
BackupPC-3.2.1-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/BackupPC-3.2.1-6.fc15

Comment 6 Fedora Update System 2011-09-26 23:05:57 UTC
BackupPC-3.2.1-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/BackupPC-3.2.1-6.fc14

Comment 7 Fedora Update System 2011-09-26 23:07:42 UTC
BackupPC-3.2.1-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/BackupPC-3.2.1-6.el6

Comment 8 Fedora Update System 2011-09-26 23:08:42 UTC
BackupPC-3.2.1-6.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/BackupPC-3.2.1-6.el5

Comment 9 Fedora Update System 2011-09-27 17:31:49 UTC
Package BackupPC-3.2.1-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing BackupPC-3.2.1-6.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/BackupPC-3.2.1-6.fc16
then log in and leave karma (feedback).

Comment 10 Bernard Johnson 2011-10-07 15:28:42 UTC
*** Bug 744218 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2011-10-08 17:59:35 UTC
BackupPC-3.2.1-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-10-08 18:00:16 UTC
BackupPC-3.2.1-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-10-09 19:37:15 UTC
BackupPC-3.2.1-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Nicolas Troncoso Carrere 2011-10-10 20:37:13 UTC
I just updated to:
BackupPC.x86_64 0:3.2.1-6.fc15 

and had the same issue:

BackupPC-3.2.1-4.fc15.x86_64                                                                                                                                             
Non-fatal POSTUN scriptlet failure in rpm package BackupPC
/var/tmp/rpm-tmp.jzEXSd: line 15: syntax error near unexpected token `fi'
/var/tmp/rpm-tmp.jzEXSd: line 15: `fi'
warning: %postun(BackupPC-3.2.1-4.fc15.x86_64) scriptlet failed, exit status 2

Comment 15 Bernard Johnson 2011-10-10 23:28:16 UTC
See comment #3.

Comment 16 Fedora Update System 2011-10-12 21:57:18 UTC
BackupPC-3.2.1-6.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2011-10-12 21:57:48 UTC
BackupPC-3.2.1-6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.