Bug 73701 - neat should add optional string wep key
neat should add optional string wep key
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
All Linux
high Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks: 81720
  Show dependency treegraph
 
Reported: 2002-09-08 20:45 EDT by Warren Togami
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-11 10:08:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-09-08 20:45:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
The "Wireless Settings" tab of neat allows you to enter the WEP key in hex. 
Many wireless users may be unfamiliar with the hex key because they have only
seen the string key.

Please consider adding to a future release of neat an optional field for string
WEP key.  This should be fairly easy to add to neat because iwconfig itself
handles the conversion from string to hex.

e.g.
iwconfig eth1 key <HEX WEP KEY>
iwconfig eth1 key s:<STRING WEP KEY>
Comment 1 Warren Togami 2002-12-24 00:22:19 EST
Phoebe's redhat-config-network does not yet have a field for optional string
key.    The field is labelled "Key:" which is ambiguous, because the user wont
know whether it wants the string or hex key.  Due to this ambiguity I no longer
consider this a RFE.
Comment 2 Warren Togami 2003-01-31 05:39:02 EST
Are you working on this?  If not and this fix can go in within 3 weeks, I can
begin work on an implementation.  Just let me know if that window of time is
okay for this release.

(I don't know Python or gtk yet, but I should learn it...)
Comment 3 Harald Hoyer 2003-01-31 05:46:36 EST
will work on it... patience
Comment 4 Harald Hoyer 2003-02-05 07:55:52 EST
ok, implemented in CVS... will be in 1.1.95
Comment 5 Harald Hoyer 2003-08-11 10:08:08 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html

Note You need to log in before you can comment on or make changes to this bug.