Bug 737012 - gnome-control-center screen -> trap divide error in gnome-settings-daemon
Summary: gnome-control-center screen -> trap divide error in gnome-settings-daemon
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 11:05 UTC by sangu
Modified: 2011-09-09 13:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 13:26:27 UTC


Attachments (Terms of Use)
~/.xsession-error (15.52 KB, text/plain)
2011-09-09 12:03 UTC, sangu
no flags Details

Description sangu 2011-09-09 11:05:59 UTC
Description of problem:
$ dmesg 
[...]
[23279.819151] gnome-settings-[10869] trap divide error ip:7f2ad4210129 sp:7fff579fe7f0 error:0 in libpower.so[7f2ad4202000+17000]
[23799.623447] gnome-settings-[6354] trap divide error ip:7f3fb3111129 sp:7fff7acf1be0 error:0 in libpower.so[7f3fb3103000+17000]
[23876.599475] gnome-settings-[6789] trap divide error ip:7f32b67ca129 sp:7fff92835320 error:0 in libpower.so[7f32b67bc000+17000]
[34186.424187] gnome-settings-[6826] trap divide error ip:7fdc94fd2129 sp:7fffa785b5f0 error:0 in libpower.so[7fdc94fc4000+17000]
[39086.003766] gnome-settings-[10903] trap divide error ip:7fee09e7d129 sp:7fff6fd0dfe0 error:0 in libpower.so[7fee09e6f000+17000]
[39129.759498] gnome-settings-[13033] trap divide error ip:7f8ba2ca0129 sp:7fff599742e0 error:0 in libpower.so[7f8ba2c92000+17000]
[39237.385631] gnome-settings-[13360] trap divide error ip:7faa06883129 sp:7fff2165acd0 error:0 in libpower.so[7faa06875000+17000]
[39274.918563] gnome-settings-[13883] trap divide error ip:7ff658efb129 sp:7fff1c7efac0 error:0 in libpower.so[7ff658eed000+17000]


Version-Release number of selected component (if applicable):
3.1.91-1.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1. gnome-control-center screen
2.
3.
  
Actual results:


Expected results:


Additional info:
gnome-settings-daemon-3.1.91-1.fc16.x86_64

Comment 1 sangu 2011-09-09 12:03:50 UTC
Created attachment 522314 [details]
~/.xsession-error

Doing second gnome-control-center screen, gnome logout(Oh no! Something has gone wrong).

Comment 2 Matthias Clasen 2011-09-09 13:26:27 UTC
Looks like https://bugzilla.gnome.org/show_bug.cgi?id=657364
which was recently fixed upstream.


Note You need to log in before you can comment on or make changes to this bug.