Bug 737015 - IPv6/dnsmasq issue
Summary: IPv6/dnsmasq issue
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openstack-nova
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 11:13 UTC by Mark McLoughlin
Modified: 2011-10-13 04:37 UTC (History)
5 users (show)

Fixed In Version: openstack-nova-2011.3-3.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-13 04:37:31 UTC


Attachments (Terms of Use)

Description Mark McLoughlin 2011-09-09 11:13:05 UTC
Seeing this error:

(nova): TRACE: Command: sudo FLAGFILE=/etc/nova/nova.conf NETWORK_ID=1 dnsmasq --strict-order --bind-interfaces --interface=br0 --conf-file= --domain=novalocal --pid-file=/var/lib/nova/networks/nova-br0.pid --listen-address=10.0.0.1 --except-interface=lo --dhcp-range=10.0.0.2,static,120s --dhcp-lease-max=256 --dhcp-hostsfile=/var/lib/nova/networks/nova-br0.conf --dhcp-script=/usr/bin/nova-dhcpbridge --leasefile-ro
(nova): TRACE: Exit code: 2
(nova): TRACE: Stdout: ''
(nova): TRACE: Stderr: '\ndnsmasq: failed to create listening socket for fe80::fc16:3eff:fe1d:632: No such device or address\n'

where this is the IPv6 address on br0:

  $ ip addr show br0
  6: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether fe:16:3e:1e:1c:31 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.1/24 brd 10.0.0.255 scope global br0
    inet6 fe80::fc16:3eff:fe1d:632/64 scope link 
       valid_lft forever preferred_lft forever

Comment 1 Mark McLoughlin 2011-09-09 11:30:11 UTC
To reproduce, just restart the network service when there's an instance running - the IPv6 address appears to get added to the bridge when you first start an instance

Comment 2 Mark McLoughlin 2011-09-09 11:38:53 UTC
deleting the IPv6 address with e.g.

 $> ip addr del fe80::fc16:3eff:fe1d:632/64 dev br0

allows the network service to start again

Comment 3 Mark McLoughlin 2011-09-21 13:51:49 UTC
Upstream bug is:

  https://bugs.launchpad.net/nova/+bug/853892

Should be fixed in diablo by:

  a) removing --interface= from the dnsmasq flags because of this:

    http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/2011q3/005247.html

  b) fixing the ordering of IP address on the bridge so that dnsmasq
     actually sees the requests

https://code.launchpad.net/~vishvananda/nova/new-dnsmasq/+merge/76096
https://code.launchpad.net/~vishvananda/nova/fix-dhcp-ms/+merge/76361

Comment 4 Fedora Update System 2011-09-23 05:43:53 UTC
openstack-nova-2011.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/openstack-nova-2011.3-1.fc16

Comment 5 Fedora Update System 2011-09-24 20:51:27 UTC
Package openstack-nova-2011.3-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openstack-nova-2011.3-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/openstack-nova-2011.3-1.fc16
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-09-28 16:08:16 UTC
openstack-nova-2011.3-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/openstack-nova-2011.3-3.fc16

Comment 7 Fedora Update System 2011-10-13 04:37:31 UTC
openstack-nova-2011.3-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.