Bug 737064 - umount: /var/tmp/imgcreate-.../install_root/sys/fs/selinux/load: not found
Summary: umount: /var/tmp/imgcreate-.../install_root/sys/fs/selinux/load: not found
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 13:51 UTC by Mads Kiilerich
Modified: 2012-04-13 21:34 UTC (History)
7 users (show)

Fixed In Version: livecd-tools-17.4-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-19 00:33:00 UTC


Attachments (Terms of Use)

Description Mads Kiilerich 2011-09-09 13:51:40 UTC
With livecd-tools-16.5-1.fc16.x86_64 I have started getting errors like 
  umount: /var/tmp/imgcreate-neqeMN/install_root/sys/fs/selinux/load: not found
after the livecd-creator image building has completed. The image works fine.

I haven't been able to figure out why - the code looks correct. My best bet would be if /sys/fs/selinux has been (lazily) unmounted before it tries to umount the fake load mount.

Comment 1 Henry Huang 2011-11-22 06:28:59 UTC
I also the same problem on the latest live-tools source codes.
http://git.fedorahosted.org/git/?p=livecd;a=summary
In the process of mount/umount, both have this error.
mount:  install_root/sys/fs/selinux/load: not exist
umount: install_root/sys/fs/selinux/load: not found

Comment 2 Brian Lane 2011-11-29 18:14:23 UTC
Do you have selinux enabled on the build host? Are you building an image with selinux enabled or disabled? It is probably some combination of those two settings.

Comment 3 Mads Kiilerich 2011-11-29 18:18:09 UTC
On the build host I have SE enabled but permissive (otherwise I get too many errors and don't trust the image).

I am building an image that has selinux --enforcing.

Comment 4 Brian Lane 2012-01-19 00:06:21 UTC
Does /sys/fs/selinux exist on the buildhost? And is there a line in the logs about skipping it? I suspect this is caused by a host/target mismatch of the selinux mountpoint. I'm seeing it on my F15 system with selinux disabled on the host.

Comment 5 Mads Kiilerich 2012-01-19 00:18:59 UTC
I don't have the machine right and can't give the full answer now, but:

SELinux do in general work fine on the host machine, so I assume /sys/fs/selinux is correctly mounted.

Which logs should mention any skipping and exactly how should the line look like? (I haven't noticed it and I assume I would have noticed it if it was a place I would look ... but that doesn't prove anything.)

I do however run updates-testing on the build host and only updates on the image I compose. The policy version might thus be "slightly" different. Do you expect that is enough to cause this?

Comment 6 Brian Lane 2012-01-19 18:31:16 UTC
It looks like this when I run with -v -d --logfile=build.log

Extending sparse file /var/tmp/imgcreate-VXruDL/tmp-aABXm_/ext3fs.img to 1073741824
Mounting /dev/loop3 at /var/tmp/imgcreate-VXruDL/install_root
Skipping (/sys/fs/selinux,/sys/fs/selinux) because source doesn't exist.
Retrieving http://mirrors.kernel.org/fedora/development/rawhide/x86_64/os/repodata/repomd.xml ...OK

A policy difference shouldn't be enough, it is the mountpoint that's having problems.

Comment 7 Fedora Update System 2012-03-01 18:00:21 UTC
livecd-tools-16.11-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/livecd-tools-16.11-1.fc16

Comment 8 Fedora Update System 2012-04-13 21:34:35 UTC
livecd-tools-16.11-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.