Bug 737094 - ERROR: Not a Xen-ELF image: No ELF notes or '__xen_guest' section found
Summary: ERROR: Not a Xen-ELF image: No ELF notes or '__xen_guest' section found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: ---
Assignee: David Cantrell
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 691780 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-09 15:34 UTC by Alexander Todorov
Modified: 2011-12-06 10:41 UTC (History)
1 user (show)

Fixed In Version: anaconda-13.21.140-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 10:41:27 UTC


Attachments (Terms of Use)
737094.img (27.06 KB, application/octet-stream)
2011-09-13 13:24 UTC, David Cantrell
no flags Details
737094.img (27.05 KB, application/octet-stream)
2011-09-15 16:02 UTC, David Cantrell
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1565 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2011-12-06 00:39:12 UTC

Description Alexander Todorov 2011-09-09 15:34:01 UTC
Description of problem:

I hit an error right after install of 6.2 Xen guest completed. The guest included all packages available in the tree. The error from virt-manager is this:

DEBUG (error:76) Uncaught Error: Error starting domain: грешка при POST операция: xend_post: error from xen daemon: (xend.err 'Error creating domain: (2, \'Invalid kernel\', "elf_xen_note_check: ERROR: Not a Xen-ELF image: No ELF notes or \'__xen_guest\' section found.\\n")') : Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 501, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 576, in startup
    self.vm.create()
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 333, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: грешка при POST операция: xend_post: error from xen daemon: (xend.err 'Error creating domain: (2, \'Invalid kernel\', "elf_xen_note_check: ERROR: Not a Xen-ELF image: No ELF notes or \'__xen_guest\' section found.\\n")')


In an everything package set install tboot is installed and I believe it is causing the problem.

Version-Release number of selected component (if applicable):
host: 
RHEL 5.7, x86_64

guest: 
RHEL6.2-20110907.1
kernel-2.6.32-195.el6
tboot-1.5.0-0.1.20110714.el6

How reproducible:


Steps to Reproduce:
1. Using RHEL 5.7 Xen dom0 initiate install of latest RHEL 6.2 tree as PV guest
2. Use kickstart with
%packages
*
-@conflicts-server

3. Complete the install and reboot
  
Actual results:
Guest doesn't start

Expected results:
Guest starts

Additional info:
@everything package set installs and boots fine under KVM.

grub.conf from the guest looks like:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/mapper/vg_test100-lv_root
#          initrd /initrd-[generic-]version.img
#boot=/dev/xvda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux (2.6.32-195.el6.x86_64)
	root (hd0,0)
	kernel /tboot.gz logging=vga.serial,memory
	module /vmlinuz-2.6.32-195.el6.x86_64 ro root=/dev/mapper/vg_test100-lv_root intel_iommu=on rd_NO_LUKS LANG=en_US.UTF-8 rd_NO_MD quiet SYSFONT=latarcyrheb-sun16 rhgb crashkernel=auto rd_LVM_LV=vg_test100/lv_swap  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rd_LVM_LV=vg_test100/lv_root
	module /initramfs-2.6.32-195.el6.x86_64.img
title Red Hat Enterprise Linux-debug (2.6.32-195.el6.x86_64.debug)
	root (hd0,0)
	kernel /tboot.gz logging=vga.serial,memory
	module /vmlinuz-2.6.32-195.el6.x86_64.debug ro root=/dev/mapper/vg_test100-lv_root intel_iommu=on rd_NO_LUKS LANG=en_US.UTF-8 rd_NO_MD quiet SYSFONT=latarcyrheb-sun16 rhgb crashkernel=auto rd_LVM_LV=vg_test100/lv_swap  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rd_LVM_LV=vg_test100/lv_root
	module /initramfs-2.6.32-195.el6.x86_64.debug.img


Changing it to disable tboot allowed me to boot fine:

title Red Hat Enterprise Linux (2.6.32-195.el6.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.32-195.el6.x86_64 ro root=/dev/mapper/vg_test100-lv_root intel_iommu=on rd_NO_LUKS LANG=en_US.UTF-8 rd_NO_MD quiet SYSFONT=latarcyrheb-sun16 rhgb crashkernel=auto rd_LVM_LV=vg_test100/lv_swap  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rd_LVM_LV=vg_test100/lv_root
	initrd /initramfs-2.6.32-195.el6.x86_64.img

Comment 1 David Cantrell 2011-09-13 13:24:35 UTC
Created attachment 522929 [details]
737094.img

Please try again using this updates.img file.

Comment 2 Alexander Todorov 2011-09-14 13:21:17 UTC
I didn't have any luck with this updates.img. Same error as before. Guest can't start.

Comment 3 David Cantrell 2011-09-14 18:11:23 UTC
Is there anything in /proc/xen on the guest?  I was using this code from rhel5-branch of anaconda to see if we are running in a Xen guest:

def inXen():
    if os.path.exists("/proc/xen/capabilities"):
        return True
    return False

Comment 4 Alexander Todorov 2011-09-15 10:17:37 UTC
(In reply to comment #3)
> Is there anything in /proc/xen on the guest?  

Nope. It's an empty directory.

Comment 5 David Cantrell 2011-09-15 16:02:45 UTC
Created attachment 523398 [details]
737094.img

OK, here's a new updates.img to try out.

Comment 6 Alexander Todorov 2011-09-16 07:46:24 UTC
the new updates.img works for me. xen guest can boot with tboot installed.

Comment 7 David Cantrell 2011-09-16 13:23:30 UTC
Thanks for testing that out, can we get a qa_ack+

Comment 10 Alexander Todorov 2011-11-03 14:27:04 UTC
Fixed in anaconda-13.21.147-1.

Comment 11 errata-xmlrpc 2011-12-06 10:41:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1565.html


Note You need to log in before you can comment on or make changes to this bug.