Bug 737095 - Unable to start a systemtap server: /usr/libexec/systemtap/stap-serverd did not start
Summary: Unable to start a systemtap server: /usr/libexec/systemtap/stap-serverd did n...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: systemtap
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Dave Brolley
QA Contact: qe-baseos-tools
URL:
Whiteboard:
: 739700 (view as bug list)
Depends On:
Blocks: 691780
TreeView+ depends on / blocked
 
Reported: 2011-09-09 15:41 UTC by Alexander Todorov
Modified: 2011-12-06 15:54 UTC (History)
6 users (show)

Fixed In Version: systemtap-1.6-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 15:18:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1517 normal SHIPPED_LIVE systemtap bug fix and enhancement update 2011-12-06 00:50:46 UTC

Description Alexander Todorov 2011-09-09 15:41:48 UTC
Description of problem:

After install of KVM guest with all packages (@everything) I see this:

Starting stap-server -a "x86_64" -r "2.6.32-195.el6.x86_64" -u "stap-server"
/usr/libexec/systemtap/stap-start-server: line 51:  2231 Aborted                 ${stap_pkglibexecdir}stap-serverd "$@" < /dev/null > /dev/null 2> /dev/null
Unable to start a systemtap server: /usr/libexec/systemtap/stap-serverd did not start
                                                           [FAILED]


Version-Release number of selected component (if applicable):
systemtap-server-1.6-2.el6.x86_64

How reproducible:


Steps to Reproduce:
1. Perform @everything installation of KVM guest.
2.
3.
  
Actual results:
service didn't start

Expected results:
service starts

Additional info:

Comment 1 Dave Brolley 2011-09-13 15:14:33 UTC
commit 3845290458cd498e490078318ae5306911cb47a9

A NULL pointer returned by getlogin was being used to initialize a std::string object.

This problem affects systemtap releases 1.5 and 1.6.

Comment 2 Dave Brolley 2011-09-14 20:28:31 UTC
commit e91c276f51fa85a62f8e2996ff4b94909a2a14f7 should be included in the fix for this problem. It reworks part of the server start up which was changed by commit 3845290458cd498e490078318ae5306911cb47a9.

Comment 3 Dave Brolley 2011-09-15 19:26:52 UTC
commit ba354d3072f0df3f1581b0fba8aa7d92a16e0362 should be included in the fix for this problem. It reworks a systemtap.spec change made in commit e91c276f51fa85a62f8e2996ff4b94909a2a14f7.

Comment 4 Frank Ch. Eigler 2011-09-20 14:38:00 UTC
*** Bug 739700 has been marked as a duplicate of this bug. ***

Comment 7 IBM Bug Proxy 2011-09-26 11:11:36 UTC
------- Comment From Subrata Modak subrata@linux.vnet.ibm.com 2011-09-26 07:04 EDT-------
Hello RH,

Any fix in sight for this ?

Regards--
Subrata

Comment 8 Frank Ch. Eigler 2011-09-26 11:32:44 UTC
> Any fix in sight for this ?

Yes, a fix from git systemtap has been backported to the $FIXED_IN_VERSION
build that should be in the beta, or immediately thereafter.

Comment 9 IBM Bug Proxy 2011-10-03 07:20:43 UTC
------- Comment From Subrata Modak subrata@linux.vnet.ibm.com 2011-10-03 03:15 EDT-------
(In reply to comment #15)
> > Any fix in sight for this ?
>
> Yes, a fix from git systemtap has been backported to the $FIXED_IN_VERSION
> build that should be in the beta, or immediately thereafter.

Hello RH,

The fix did not make beta as i do not see any change in Systemtap packages in Beta1 release:

Starting stap-server -a "powerpc" -r "2.6.32-202.el6.ppc64" -u "stap-server"
/usr/libexec/systemtap/stap-start-server: line 51:  1816 Aborted                 ${stap_pkglibexecdir}stap-serverd "$@" < /dev/null > /dev/null 2> /dev/null

# rpm -qa | grep -i systemtap
systemtap-server-1.6-2.el6.ppc64
systemtap-runtime-1.6-2.el6.ppc64
systemtap-1.6-2.el6.ppc64
systemtap-sdt-devel-1.6-2.el6.ppc64
systemtap-grapher-1.6-2.el6.ppc64
systemtap-initscript-1.6-2.el6.ppc64

# uname -a
Linux saturnfo-lp3.ltc.austin.ibm.com 2.6.32-202.el6.ppc64 #1 SMP Wed Sep 21 15:34:31 EDT 2011 ppc64 ppc64 ppc64 GNU/Linux

# cat /etc/issue
Red Hat Enterprise Linux Server release 6.2 Beta (Santiago)
Kernel \r on an \m

Regards--
Subrata

Comment 10 IBM Bug Proxy 2011-10-17 07:33:00 UTC
------- Comment From Subrata Modak subrata@linux.vnet.ibm.com 2011-10-17 03:25 EDT-------
Will test on SS1 and let you know.

Regards--
Subrata

Comment 11 IBM Bug Proxy 2011-10-18 09:02:40 UTC
------- Comment From Subrata Modak subrata@linux.vnet.ibm.com 2011-10-18 04:54 EDT-------
With the following new packages, the issue is resolved:

# rpm -qa | grep -i systemtap
systemtap-initscript-1.6-3.el6.ppc64
systemtap-server-1.6-3.el6.ppc64
systemtap-1.6-3.el6.ppc64
systemtap-grapher-1.6-3.el6.ppc64
systemtap-sdt-devel-1.6-3.el6.ppc64
systemtap-runtime-1.6-3.el6.ppc64

Hello RH, thanks very much for your support.

Regards--
Subrata

Comment 13 errata-xmlrpc 2011-12-06 15:18:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1517.html


Note You need to log in before you can comment on or make changes to this bug.