Bug 737120 - No Operations available for Resources
Summary: No Operations available for Resources
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: RHQ Project
Classification: Other
Component: Operations
Version: 4.1
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: jon30-bugs rhq42
TreeView+ depends on / blocked
 
Reported: 2011-09-09 16:38 UTC by Douglas Woods
Modified: 2011-10-14 20:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-14 20:26:17 UTC


Attachments (Terms of Use)
JON Beta v3.0 Server log (407.90 KB, text/x-log)
2011-09-12 19:43 UTC, Douglas Woods
no flags Details
JON Agent v3.0 log (6.89 MB, text/x-log)
2011-09-12 19:44 UTC, Douglas Woods
no flags Details

Description Douglas Woods 2011-09-09 16:38:58 UTC
Description of problem:
No Operations show for resources under the "Operations Tab".


Version-Release number of selected component (if applicable):
3.0.0 Beta
RHEL 6.1 x86_64

How reproducible:
Select the Operations Tab on the RHQ Agent or RHQ Server.

Steps to Reproduce:
1.Boot up JON Server and logged into the console
2.Select Inventory=>Servers=>RHQ Server
3.Select Operations Tab
  
Actual results:
No Operations

Expected results:
Operations of "Start", "Restart", "Stop"

Additional info:

Comment 1 Charles Crouch 2011-09-12 17:49:44 UTC
QE, can you verify if you are seeing this? It strike me as very odd these operations are not available

Comment 2 Charles Crouch 2011-09-12 17:57:16 UTC
It would be worth checking whether the operations are there for all of the following:

-the RHQ Server
-an EAP4.x server 
-an EAP5.x server

Comment 3 Mike Foley 2011-09-12 19:23:07 UTC
verifying JON 3.0 Beta ... 


On RHQ Server resource, I see operations start, restart, and shutdown.
On EAP6/AS7 server, I see operations reload, restart, shutdown, and start.
On EAP5, I see operations start, restart, and shutdown.

I do not see the same behavior as the customer.

Comment 4 Charles Crouch 2011-09-12 19:30:33 UTC
Doug,
We can't reproduce this. Can you try this again and include agent and server side debug logs.

Thanks
Charles

Comment 5 Douglas Woods 2011-09-12 19:43:12 UTC
Charles,
I confirmed with Uday that he was seeing the same issue before opening this bugzilla.

I will reinventory the RHQ Server and attached are my agent/server debug logs.

Comment 6 Douglas Woods 2011-09-12 19:43:57 UTC
Created attachment 522763 [details]
JON Beta v3.0 Server log

JON Beta v3.0 Server log

Comment 7 Douglas Woods 2011-09-12 19:44:36 UTC
Created attachment 522764 [details]
JON Agent v3.0 log

JON Agent v3.0 log

Comment 8 Charles Crouch 2011-09-27 13:06:10 UTC
Review logs and determine if there are other issues besides the one being 
reported.
Re: missing operations, try to reproduce if possible

Comment 9 Charles Crouch 2011-10-05 15:56:36 UTC
Joe F may have hit on the issue...

> 
> I am not sure if this is the issue, but in JON 3.0 UI when you go to
> the Operations tab you won't see the supported operations for the
> resource listed in a table like you did in JON 2.4.1. This may give
> the impression that there aren't any supported operations for that
> resource (at least it did for me initially). If you click on the
> "New" button at the bottom of the Operations tab, then you should
> see the supported operations available to select from a drop-down
> list.

Comment 10 Douglas Woods 2011-10-05 16:18:21 UTC
This is the issue. When following Joe F's information operations are available.

Comment 11 Douglas Woods 2011-10-14 20:26:17 UTC
Closing this bugzilla with issue resolved per Joe F information.


Note You need to log in before you can comment on or make changes to this bug.