Bug 73713 - Installer crashes on Compaq Proliant 1600
Installer crashes on Compaq Proliant 1600
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-09 05:50 EDT by Neil Bingham
Modified: 2005-10-31 17:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-09 20:24:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Bingham 2002-09-09 05:50:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
After you get the message saying anaconda is running it goes off to probe the
hardware.  It correctly identifies the graphics card and monitor, but then
completely crashes.  I cannot switch to any of the other consoles to see if
there is any debugging to report.

Having read bug 72776 I removed the server from our Belkin KVM but this made no
difference.

I have also had this exact same problem with Redhat 7.3, but Redhat 7.2 installs
correctly.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot off the installation CD
2. Select Graphics or Text install (it doesn't matter)
3. Skip media test.
4. As soon as anaconda runs and probes the monitor it then crashes
	

Actual Results:  Get output from anaconda showing Graphics card and monitor and
then the cursor _ on the next line.  The box is completely locked up so you
can't get to any of the other consoles.

Expected Results:  Anaconda should have gone into the installation screens.

Additional info:

After experiencing this problem with bothe Null & 7.3 I upgraded the BIOS to the
latest provided by Compaq.  No change.
Comment 1 Jeremy Katz 2002-09-09 11:47:10 EDT
Does it work better if you boot with 'linux skipddc'?
Comment 2 Neil Bingham 2002-09-09 12:13:35 EDT
Unfortunately not.

Still locks up in the same place, and can't get to the other consoles.
Comment 3 Michael Fulbright 2002-09-23 17:31:21 EDT
You can try 'nousb' as well.
Comment 4 Neil Bingham 2002-09-24 05:20:02 EDT
'nousb' makes no change.  Still crashes in exactly the same place.  This edition
of the Proliant mainboard doesn't have USB hardware.

Comment 5 Michael Fulbright 2002-10-02 15:58:42 EDT
Could you please try with the final 8.0 release now it is out?
Comment 6 Neil Bingham 2002-10-03 04:05:15 EDT
Still crashes in the same way.  No difference in behaviour.
Comment 7 Michael Fulbright 2002-10-03 16:25:10 EDT
I will see if we have this hardware available here to verify the issue on.
Comment 8 Alan Cox 2002-10-03 17:42:23 EDT
What video card also - proliants shipped with a range of video including cirrus
and matrox 
Comment 9 Pete B. 2002-10-03 17:44:00 EDT
FYI: I have had the exact same problem with my ProLiant 1600. My 1600 is a 
450MHzx1 processor, 64MB, no RAID. Versions 7.3 and 8.0 fail exactly the same 
way but 7.2 installed with no problem. I have tested with 8.0 final. I have 
also tried every kernel boot option with no luck. I am adding myself to the CC 
list because I would love to have a resolution also! :-)
Comment 10 Neil Bingham 2002-10-04 04:00:12 EDT
As requested the graphics card details:

Xconfigurator in Redhat 7.2 detected it as a Cirrus Logic GD544x
Comment 11 Need Real Name 2002-10-09 20:24:49 EDT
I am having the "same?" problem on Proliant 1600 P2-400 single and 1850R p2-450
dual cpu systems under 8.0.

However, anaconda does not always hang. At times it gets past the "Display detect"
phase, proclaims "no mouse detected" and the install continues. It seems to be
messing with the bus that the keyboard and mouse are on at the time and not
getting it right all the time.
Kudzu will
later detect the mouse. During the continue of the install under anaconda
I can beebop around with tab and arrow keys, but the keyboard is real sluggish.
When I install 7.2 on these systems, the monitor is correctly ID'd as a compaq S710
Under 8.0 , it shows up as an Unknown type. This leads me to believe that the
Production CDROM set is missing anaconda related configuration files particular to
the Compaq series of systems. It therefore fails to properly detect the hardware
chipsets on the motherboard and uses a somewhat compatible, but incorrect driver.

Can you diff the anaconda system between 7.2 and the 8.0 production cdroms to
determine what might have changed or be missing from the 7.3/8.0 sets.
I though 7.3 was certified on all compaq proliant series hardware?
I know you have not done it on 8.0 levels.

I had a wacky problem with anaconda under 7.1. At times it would hang, but a
system reboot
would clear mthings out sometimes and the install would succeed. 

Maybe there is a bug in how anaconda resets the hardware as it probes the busses.
It may not be doing an initial "Clear to default boot state" to get things
into a standard "known" state.

Anyway to put anaconda into a more verbose debug mode so we can all tell you
where it hangs?  Otherwise you could fast ship me a boot cdrom with debug
enabled on the installation program suite, recording logs etc to floppy disk
files. My systems are idle waiting for 8.0 to be installed, so i can play around
and collect data for you and email the logs to you.

You are "dealing" with someone (me) with 26 years of hardware and UNIX kernel
source experience. I might be more likely to help you nail this problem down
faster than a newbie.

My gut tells me that something got left out on the cdroms related specifically to
Compaq systems. We did sucessfully install 8.0 on a High end dell poweredge
server with hardware raid last week and It did boot ona  clone Asus motherboard PC.

tech support made some suggestions regarding (boot apic, noapic)
which I will try. I dont think that is the problem. I really think
the disks are missing the files that properly id compaq hardware for anaconda
during it's probes.
Comment 12 Michael Fulbright 2002-10-24 16:50:50 EDT
I do not have this hardware available so I cannot replicate this issue.

Some hw is simply not compatible.
Comment 13 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated
Comment 14 Neil Bingham 2003-05-12 12:51:00 EDT
Installation works fine using Redhat 9.
Comment 15 Arndt Koenigsfeld 2003-09-22 04:56:27 EDT
I had similiar problems with Redhat 9.

I was able to install with text mode only once.

Then kickstart installation attempts failed and i was not able to do a manual
installation aftwards.
I checked the hardware and got same problems on an identical second machine.
I wonder how i got it installed and found a solution.

  append text apm=3Doff lowres noapic noht nomce nousb nousbstorage skipddc

and it will install.







Note You need to log in before you can comment on or make changes to this bug.