Bug 737138 - Roles > Permissions/Users: Tabbing through elements does not access all elements
Summary: Roles > Permissions/Users: Tabbing through elements does not access all elements
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-09 17:52 UTC by Corey Welton
Modified: 2013-08-16 18:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:56:35 UTC


Attachments (Terms of Use)

Description Corey Welton 2011-09-09 17:52:25 UTC
Description of problem:
When A user is on a Roles > Permissions page (either global or org) or Roles > Users and begins tabbing through the elements, it becomes evident that user cannot tab through all elements on page, particularly the 'footer' buttons (add permission, edit role, remove role)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Navigate to any of these pages, particularly to an Create or Update operation, as applicable.
2.  Hit tab repeatedly while cycling through all available elements
3.  View results
  
Actual results:
Tab cycles avoid the buttons at the bottom of the UI

Expected results:
User should be able to tab to the footer buttons.

Additional info:

Comment 1 Eric Helms 2011-10-03 17:35:32 UTC
commit 17938083a832ea57b56686c274eb9d5096a12db5

Adds action bar items on Roles page to tab index such that they can now be tabbed through.  The enter button will now cause the action bar event to trigger for the focused button.

Comment 2 Corey Welton 2012-01-23 17:40:18 UTC
QA Verified.

Comment 5 Mike McCune 2013-08-16 18:03:38 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.