Bug 737146 - [abrt] sugar-0.93.4-1.fc16: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/datastore-service exited with status 1
Summary: [abrt] sugar-0.93.4-1.fc16: connection.py:630:call_blocking:DBusException: or...
Keywords:
Status: CLOSED DUPLICATE of bug 737150
Alias: None
Product: Fedora
Classification: Fedora
Component: sugar
Version: 16
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Simon Schampijer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5409582316c26d512ca9c88ec92...
Depends On:
Blocks: F16Beta-accepted, F16BetaFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2011-09-09 18:47 UTC by satellit
Modified: 2011-09-12 10:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-12 10:10:29 UTC


Attachments (Terms of Use)

Description satellit 2011-09-09 18:47:24 UTC
abrt version: 2.0.5
cmdline:        
comment:        try to start sugar-desktop from sugar-emulator
executable:     /usr/bin/sugar-session
kernel:         3.1.0-0.rc4.git0.0.fc16.i686.PAE
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/datastore-service exited with status 1
time:           Fri Sep  9 11:46:15 2011
uid:            1000
username:       robert

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/datastore-service exited with status 1
:
:Traceback (most recent call last):
:  File "/usr/bin/sugar-session", line 281, in <module>
:    main()
:  File "/usr/bin/sugar-session", line 224, in main
:    from jarabe.desktop import homewindow
:  File "/usr/lib/python2.7/site-packages/jarabe/desktop/homewindow.py", line 25, in <module>
:    from jarabe.desktop.meshbox import MeshBox
:  File "/usr/lib/python2.7/site-packages/jarabe/desktop/meshbox.py", line 48, in <module>
:    from jarabe.journal import misc
:  File "/usr/lib/python2.7/site-packages/jarabe/journal/misc.py", line 26, in <module>
:    from sugar.activity import activityfactory
:  File "/usr/lib/python2.7/site-packages/sugar/activity/activityfactory.py", line 34, in <module>
:    from sugar.datastore import datastore
:  File "/usr/lib/python2.7/site-packages/sugar/datastore/datastore.py", line 77, in <module>
:    _get_data_store()
:  File "/usr/lib/python2.7/site-packages/sugar/datastore/datastore.py", line 51, in _get_data_store
:    DS_DBUS_PATH),
:  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 244, in get_object
:    follow_name_owner_changes=follow_name_owner_changes)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 241, in __init__
:    self._named_service = conn.activate_name_owner(bus_name)
:  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 183, in activate_name_owner
:    self.start_service_by_name(bus_name)
:  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 281, in start_service_by_name
:    'su', (bus_name, flags)))
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/datastore-service exited with status 1
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus._dbus.SessionBus (session) at 0x8fbf4ac>
:args: ('org.laptop.sugar.DataStore', 0)
:utf8_strings: False
:bus_name: 'org.freedesktop.DBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: '/org/freedesktop/DBus'
:timeout: -1.0
:signature: 'su'
:dbus_interface: 'org.freedesktop.DBus'
:message: <dbus.lowlevel.MethodCallMessage object at 0x8edb880>
:method: 'StartServiceByName'

smolt_data:
:
:
:General
:=================================
:UUID: 13076e90-aae7-465c-b9a1-5ea047539275
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 3325.63
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Atom(TM) CPU N450   @ 1.66GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 28
:Number of CPUs: 2
:CPU Speed: 1666
:System Memory: 1992
:System Swap: 3999
:Vendor: Acer
:System: AO532h V1.05
:Form factor: Notebook
:Kernel: 3.1.0-0.rc4.git0.0.fc16.i686.PAE
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10172:4133:841) pci, None, PCI/ISA, NM10 Family LPC Controller
:(5772:42:4187:57375) pci, ath9k, NETWORK, AR928X Wireless Network Adapter (PCI-Express)
:(32902:40977:4133:841) pci, i915, VIDEO, N10 Family Integrated Graphics Controller
:(32902:40978:4133:841) pci, None, VIDEO, N10 Family Integrated Graphics Controller
:(32902:10192:4133:841) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10194:4133:841) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 2
:(6505:4194:4133:841) pci, atl1c, ETHERNET, AR8132 Fast Ethernet
:(32902:10200:4133:841) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:10202:4133:841) pci, i801_smbus, SERIAL, N10/ICH 7 Family SMBus Controller
:(32902:9288:4133:841) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10177:4133:841) pci, ahci, STORAGE, N10/ICH7 Family SATA AHCI Controller
:(32902:10185:4133:841) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:4133:841) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:40976:0:0) pci, agpgart-intel, HOST/PCI, N10 Family DMI Bridge
:(32902:10186:4133:841) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:10187:4133:841) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10188:4133:841) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda4 / ext4 4096 4096 12901535 11490507 10835147 3276800 3119513 3119513
:/dev/sda5 /home ext4 4096 4096 46055701 45998562 43659068 11698176 11697863 11697863
:/dev/sda2 /boot ext4 1024 1024 495844 461109 435509 128016 127799 127799
:

Comment 1 satellit 2011-09-09 19:04:50 UTC
Package: sugar-0.93.4-1.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
try to run sugar-emulator in terminal after completeing yum update

Comment 2 satellitgo 2011-09-09 19:34:58 UTC
NTH Blocker for sugar as sugar-desktop will not start at all
tried
1-)gdm login to sugar
2-)sugar-emulator in terminal
3-)graphical menu Education/sugar from gnome3-shell

Comment 3 satellit 2011-09-09 22:38:55 UTC
Package: sugar-0.93.4-1.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
start "sugar" =menu in gnome3-shell Education/sugar (sugar-emulator)
Install to HD from TC2 DVD Installation repo only

Previous install to HD used f16 and f16 updates repos not DVD install repo.

Comment 4 Peter Robinson 2011-09-12 10:10:29 UTC

*** This bug has been marked as a duplicate of bug 737150 ***


Note You need to log in before you can comment on or make changes to this bug.