Bug 737147 - Provide native systemd service file
Summary: Provide native systemd service file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: amanda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukáš Nykrýn
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: SysVtoSystemd
TreeView+ depends on / blocked
 
Reported: 2011-09-09 18:48 UTC by Jóhann B. Guðmundsson
Modified: 2012-09-17 23:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-17 23:41:11 UTC


Attachments (Terms of Use)
amanda socket (139 bytes, text/plain)
2011-09-09 18:48 UTC, Jóhann B. Guðmundsson
no flags Details
amanda service (184 bytes, text/plain)
2011-09-09 18:49 UTC, Jóhann B. Guðmundsson
no flags Details
Amanda service (169 bytes, text/plain)
2011-09-10 00:59 UTC, Jóhann B. Guðmundsson
no flags Details
amanda udp service (169 bytes, text/plain)
2011-09-14 13:44 UTC, Jóhann B. Guðmundsson
no flags Details
amanda udp socket (171 bytes, text/plain)
2011-09-14 13:44 UTC, Jóhann B. Guðmundsson
no flags Details
amanda tcp socket (120 bytes, text/plain)
2011-09-14 13:46 UTC, Jóhann B. Guðmundsson
no flags Details
amanda tcp service (172 bytes, text/plain)
2011-09-14 13:46 UTC, Jóhann B. Guðmundsson
no flags Details
new amanda udp socket (137 bytes, text/plain)
2011-09-15 11:30 UTC, Jóhann B. Guðmundsson
no flags Details

Description Jóhann B. Guðmundsson 2011-09-09 18:48:11 UTC
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jóhann B. Guðmundsson 2011-09-09 18:48:53 UTC
Created attachment 522380 [details]
amanda socket

Comment 2 Jóhann B. Guðmundsson 2011-09-09 18:49:29 UTC
Created attachment 522381 [details]
amanda service

Comment 3 Jóhann B. Guðmundsson 2011-09-09 18:50:37 UTC
Pasess simple telnet test to port

# telnet localhost 10080 
Trying ::1...
Connected to localhost.
Escape character is '^]'.


And note there is still a (tight) window to have this in F16

Comment 4 Jóhann B. Guðmundsson 2011-09-10 00:59:08 UTC
Created attachment 522451 [details]
Amanda service

Comment 5 Jóhann B. Guðmundsson 2011-09-10 11:40:31 UTC
Once package and shipped you package should no longer have to depend on xinetd

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

Comment 6 Lukáš Nykrýn 2011-09-14 09:16:27 UTC
I am not sure if we want to run amanda by systemd instead of xinetd. Because amanda is not enabled by default I propose that we can add unit files into the package and let user to choose.

Comment 7 Jóhann B. Guðmundsson 2011-09-14 09:25:07 UTC
Hum not following you dont enable amanda by default in systemd unless ofcourse you explicitly do that at install time ( or user does that by hand ) and enabling things by default requires sanctions from fesco afaik.

Shipping both will only cause confusion and potential conflicts which is why we dont do that with legacy sysv init script.

Comment 8 Lukáš Nykrýn 2011-09-14 11:53:44 UTC
I tried to pack amanda with systemd and I found out it behaves strangely. When it starts it constantly writes these two messages in its log file: 
amandad: dgram_recv(dgram=0x7fc334a648e8, timeout=0, fromaddr=0x7fc334a748e0)
amandad: (sockaddr_in *)0x7fc334a748e0 = { 0, 0, 0.0.0.0 }
After few minutes this log file occupies several gigabytes of disk space.

When it is started through xinetd this issue does not occur.

Comment 9 Jóhann B. Guðmundsson 2011-09-14 12:00:43 UTC
Known issue with 35

http://thread.gmane.org/gmane.comp.sysutils.systemd.devel/3267/focus=3269

Comment 10 Jóhann B. Guðmundsson 2011-09-14 12:02:27 UTC
Hum perhaps this could be a new bug. 

Could you test by downgrading to .34?

Comment 11 Lukáš Nykrýn 2011-09-14 12:36:58 UTC
I have tried this in f15, so I am using systemd-26-9.

Comment 12 Jóhann B. Guðmundsson 2011-09-14 13:44:25 UTC
Created attachment 523154 [details]
amanda udp service

Comment 13 Jóhann B. Guðmundsson 2011-09-14 13:44:54 UTC
Created attachment 523155 [details]
amanda udp socket

Comment 14 Jóhann B. Guðmundsson 2011-09-14 13:46:03 UTC
Created attachment 523156 [details]
amanda tcp socket

Comment 15 Jóhann B. Guðmundsson 2011-09-14 13:46:27 UTC
Created attachment 523157 [details]
amanda tcp service

Comment 16 Jóhann B. Guðmundsson 2011-09-14 13:46:51 UTC
Threw in a batch of fresh unit files to try both tcp and udp based

Comment 17 Lukáš Nykrýn 2011-09-15 11:08:16 UTC
It seems that tcp works fine. With udp amanda won't start when I try to connect, but I wasn't able to find why.

Comment 18 Jóhann B. Guðmundsson 2011-09-15 11:30:02 UTC
Created attachment 523349 [details]
new amanda udp socket

Comment 19 Jóhann B. Guðmundsson 2011-09-15 11:32:37 UTC
Ok good to know that tcp works I have created a new udp socket file without multiple Listen datagram entries.

Comment 20 Lukáš Nykrýn 2011-09-27 08:16:37 UTC
I think this will be a bit more complicated. This unit file is for amandad, which is client daemon in amanda. If we want to switch to systemd completely, we will need unit files for all daemons included in amanda (amandaidxd, amidxtaped) and this configuration should be compatible with amanda started by xinetd from older realeases of Fedora and RHEL.

Comment 21 Fedora Update System 2012-08-16 12:01:01 UTC
amanda-3.3.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/amanda-3.3.2-1.fc18

Comment 22 Fedora Update System 2012-08-16 16:53:35 UTC
Package amanda-3.3.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing amanda-3.3.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11996/amanda-3.3.2-1.fc18
then log in and leave karma (feedback).

Comment 23 Fedora Update System 2012-09-17 23:41:11 UTC
amanda-3.3.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.