This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 73715 - --show-package-dialog does not work unless pending updates also
--show-package-dialog does not work unless pending updates also
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Bret McMillan
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-09 05:59 EDT by Gene Czarcinski
Modified: 2015-01-07 19:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 12:00:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2002-09-09 05:59:44 EDT
Description of Problem:
In the up2date gui interface, allow the capability to download and optionally
install a package not previously installed.  This is related to bugzilla report
73714.
Comment 1 Adrian Likins 2002-09-12 17:36:20 EDT
Low on the TODO list, but there.

Comment 2 Gene Czarcinski 2002-09-12 23:19:57 EDT
did not expect much higher priority
Comment 3 Adrian Likins 2003-08-06 18:41:50 EDT
up2date --show-package-dialog  will show an extra screen
in the gui with a list of all available packages you
can select from.

Off by default since folks dont seem fond of the ui.
Comment 4 Adrian Likins 2003-08-06 18:42:18 EDT
that should be in rh9 or later, btw
Comment 5 Gene Czarcinski 2003-10-27 14:06:32 EST
--show-package-dialog does nothing
Comment 6 Gene Czarcinski 2003-11-09 12:45:08 EST
I am changing this report to better reflect existing situation.

--show-package-dialog is there and does work but only if there is a
package in the group needing updating.  Otherwise, up2date terminates
with "Your system is up to date" before the all-package display can be
performed.
Comment 7 Gene Czarcinski 2003-11-10 15:46:54 EST
OK, I see what the "problem" is.

In gui.py around between lines 1551 and 1555, if the length of the
package list (of updates) is zero, then slam-bang get out with sys.exit(0)

I am currently neither that knowledgable of python nor of the design
of this module to propose a fix.
Comment 8 John Thacker 2006-04-21 12:00:20 EDT
up2date is no longer being actively maintained in favor of pup and pirut.  Since
this is neither a security nor a critical bug, it almost surely will not get
fixed in Fedora Legacy.

Note You need to log in before you can comment on or make changes to this bug.