Bug 737153 - Provide native systemd service file
Summary: Provide native systemd service file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: authd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Roman Rakus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 18:59 UTC by Jóhann B. Guðmundsson
Modified: 2014-01-13 00:13 UTC (History)
2 users (show)

Fixed In Version: authd-1.4.3-37.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-30 13:49:16 UTC


Attachments (Terms of Use)
auth socket (117 bytes, text/plain)
2011-09-09 19:00 UTC, Jóhann B. Guðmundsson
no flags Details
auth service (187 bytes, text/plain)
2011-09-09 19:00 UTC, Jóhann B. Guðmundsson
no flags Details
authd server (173 bytes, text/plain)
2011-09-10 10:44 UTC, Jóhann B. Guðmundsson
no flags Details
auth service (173 bytes, text/plain)
2011-09-10 10:46 UTC, Jóhann B. Guðmundsson
no flags Details

Description Jóhann B. Guðmundsson 2011-09-09 18:59:38 UTC
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jóhann B. Guðmundsson 2011-09-09 19:00:17 UTC
Created attachment 522383 [details]
auth socket

Comment 2 Jóhann B. Guðmundsson 2011-09-09 19:00:42 UTC
Created attachment 522384 [details]
auth service

Comment 3 Jóhann B. Guðmundsson 2011-09-09 19:01:36 UTC
Passes simple telnet test

[root@valhalla system]# systemctl start auth.socket
[root@valhalla system]# systemctl status auth.socket
auth.socket - Authd Activation Socket
	  Loaded: loaded (/lib/systemd/system/auth.socket)
	  Active: active (listening) since Fri, 09 Sep 2011 18:57:49 +0000; 3s ago
	Accepted: 0; Connected: 0
	  CGroup: name=systemd:/system/auth.socket
[root@valhalla system]# telnet localhost 113
Trying ::1...
Connected to localhost.
Escape character is '^]'.
Connection closed by foreign host.

And note there is still a (tight) window to have this in F16

Comment 4 Jóhann B. Guðmundsson 2011-09-10 10:44:35 UTC
Created attachment 522509 [details]
authd server

Comment 5 Jóhann B. Guðmundsson 2011-09-10 10:46:21 UTC
Created attachment 522510 [details]
auth service

Comment 6 Jóhann B. Guðmundsson 2011-09-10 11:41:32 UTC
Once package and shipped you package should no longer have to depend on xinetd

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

Comment 7 Roman Rakus 2012-11-30 13:49:16 UTC
Fixed in authd-1.4.3-37.fc19


Note You need to log in before you can comment on or make changes to this bug.