Bug 737165 - File/Quit evolution fails after attempting to communicate with exchange.
Summary: File/Quit evolution fails after attempting to communicate with exchange.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution-mapi
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 782183 840699
TreeView+ depends on / blocked
 
Reported: 2011-09-09 19:08 UTC by Travis Gummels
Modified: 2018-11-28 21:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-29 21:38:47 UTC


Attachments (Terms of Use)

Description Travis Gummels 2011-09-09 19:08:15 UTC
Description of problem:
When using evolution with openchange the Exchange Mail hangs with two tasks:
"Generating message list (...)"
"Refreshing folder (...)"
 
When trying to File/Quit evolution, it just hangs and never goes away (due to the above tasks)

Version-Release number of selected component (if applicable):
evolution-2.28.3-24.el6.x86_64
evolution-mapi-0.28.3-7.4.el6.x86_64
evolution-data-server-2.28.3-15.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Attempt to use exchange mail
2. generating message list and refreshing folder never complete
3. try to quit fails
  
Actual results:
Application doesn't work

Expected results:
Application works

Additional info:

Comment 1 Milan Crha 2011-09-12 06:35:59 UTC
Thanks for a bug report. It is waiting for those tasks to be finished. As my exchange server connection works pretty good, could you get backtrace of running evolution, in which state it is stuck, please? It's possible it's updating its internal cache, which can take its time when the folder is large. You can get the backtrace of running evolution with a command like this:
   $ gdb --batch --ex "t a a bt" -pid=PID &>bt.txt
where PID is a process ID of a running evolution. Make sure you've installed debug info packages for openchange, evolution-data-server, evolution, evolution-mapi. Thanks in advance.

Comment 7 RHEL Product and Program Management 2012-07-10 06:36:04 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 8 RHEL Product and Program Management 2012-07-10 23:10:46 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.


Note You need to log in before you can comment on or make changes to this bug.