Bug 737168 - Provide native systemd service file
Summary: Provide native systemd service file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: apg
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: SysVtoSystemd
TreeView+ depends on / blocked
 
Reported: 2011-09-09 19:12 UTC by Jóhann B. Guðmundsson
Modified: 2012-01-29 05:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-29 05:45:27 UTC


Attachments (Terms of Use)
apgd socket (117 bytes, text/plain)
2011-09-09 19:13 UTC, Jóhann B. Guðmundsson
no flags Details
apgd service (207 bytes, text/plain)
2011-09-09 19:13 UTC, Jóhann B. Guðmundsson
no flags Details
Agpd service (192 bytes, text/plain)
2011-09-10 14:17 UTC, Jóhann B. Guðmundsson
no flags Details

Description Jóhann B. Guðmundsson 2011-09-09 19:12:46 UTC
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jóhann B. Guðmundsson 2011-09-09 19:13:20 UTC
Created attachment 522389 [details]
apgd socket

Comment 2 Jóhann B. Guðmundsson 2011-09-09 19:13:43 UTC
Created attachment 522390 [details]
apgd service

Comment 3 Jóhann B. Guðmundsson 2011-09-09 19:14:27 UTC
Passes simple telnet test...

[root@valhalla system]# systemctl start apgd.socket 
[root@valhalla system]# systemctl status apgd.socket 
apgd.socket - Authd Activation Socket
	  Loaded: loaded (/lib/systemd/system/apgd.socket)
	  Active: active (listening) since Fri, 09 Sep 2011 19:10:05 +0000; 3s ago
	Accepted: 0; Connected: 0
	  CGroup: name=systemd:/system/apgd.socket
[root@valhalla system]# telnet localhost 129
Trying ::1...
Connected to localhost.
Escape character is '^]'.
Hibdeot. (Hib-de-ot-PERIOD)
Sickwegs (Sick-wegs)
cozunet1 (coz-un-et-ONE)
ottIfsUn (ott-Ifs-Un)
PretFink (Pret-Fink)
RekZuor6 (Rek-Zu-or-SIX)
Connection closed by foreign host.

And note there is still a (tight) window to have this in F16

Comment 4 Jóhann B. Guðmundsson 2011-09-10 14:17:43 UTC
Created attachment 522525 [details]
Agpd service

Comment 5 Jóhann B. Guðmundsson 2011-09-10 14:18:23 UTC
Once package and shipped your package should no longer have to depend on xinetd

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

Comment 6 Jóhann B. Guðmundsson 2011-09-15 00:02:54 UTC
If I can recall correctly you ping me about this one not working where you mentioned that this was not working. 

I'm wondering if you are hitting a bug in systemd .35 where the socket out put is broken for in.inetd daemons 

You can add StandardOutput=socket to the service file to see if you are encountering that bug.

Node that this option is only needed since this only affects .35 ( not 34 or earlier ) and will be fixed in 36

Comment 7 Jóhann B. Guðmundsson 2011-09-15 00:05:47 UTC
Time is late and my english is starting to suck more then usual basically you should only add StandardOutput=socket to the service to test if you are bit by the .35 bug.

No need to add it otherwize since that bug will be fixed in .36 and only affects .35 release

Comment 8 Kevin Fenzi 2011-09-15 00:19:32 UTC
Yeah, it's .35, so that could be the issue. ;) 

Will give that a try, thanks!

Comment 9 Kevin Fenzi 2012-01-29 05:45:27 UTC
Sorry for the long delay here. Ran into two anoying problems: 

1) didn't realize that the service file needed to be apg@.service instead of apg.service. 

2) apgd needs /dev/random, so in my testing I kept running into it running out of entropy and hanging. 

Anyhow, all fixed and commited to rawhide. Thanks.


Note You need to log in before you can comment on or make changes to this bug.