Bug 73717 - The following message is appearing "kernel: request_module[net-pf-10]: fork failed, errno 12"
The following message is appearing "kernel: request_module[net-pf-10]: fork f...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-09 07:44 EDT by william ewing
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description william ewing 2002-09-09 07:44:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
AT least once a day I am getting 
kernel: request_module[net-pf-10]: fork failed, errno 12
in the messages file.
Why ?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Will appear during the day
2.
3.
	

Additional info:
Comment 1 Arjan van de Ven 2002-09-09 08:06:11 EDT
what kernel version are you using ?
Comment 2 william ewing 2002-09-09 08:16:57 EDT
Kernel Version is 2.4.9-34enterprise 
on a dual processor server with 4GB of RAM
Comment 3 Arjan van de Ven 2002-09-09 08:22:36 EDT
any chance you're using a program that creates a lot of threads ?
Comment 4 william ewing 2002-09-09 11:53:27 EDT
I believe I am using a program that generates alot of threads !
There is one deamon which generates for each person that is logging in a new 
process. ie we have 1 ADVMAIL.SCKD process and it generates 1500 UAL.REMOTE 
(one for each person that logs into the E-Mail system)
Is there a solution ?

Comment 5 william ewing 2002-09-10 08:52:10 EDT
Is there any more INFO required ?
Comment 6 Arjan van de Ven 2002-09-10 08:54:16 EDT
ok to get it clear: you get 1500 processes. Do these processes each have
threads? (I assume not, things would blow up before that ;)
Comment 7 william ewing 2002-09-11 04:38:24 EDT
orry for my ignorance

How do I get the information regarding threads that you want to know
Comment 8 Arjan van de Ven 2002-09-11 04:40:51 EDT
are you using HP OpenMail ?
Comment 9 william ewing 2002-09-11 04:46:30 EDT
Yes I am using HP OPenMail
Comment 10 william ewing 2002-10-30 03:59:38 EST
Any Update on this call ?
Comment 11 Arjan van de Ven 2002-10-31 18:32:05 EST
the only way we can go over 1200 openmail processes is with the current kernel
in rawhide ;( there is unfortionatly a 1200 (or thereabouts) hard limit in the
2.4.18 and previous kernels for processes linked against -lpthreads, openmail
does 1 per connection so there is a limit of 1200 openmail connections ;(
Comment 12 william ewing 2002-11-04 15:54:12 EST
Thanks but I had already worked that out and HP OpenMail have recompiled their 
UAL.REMOTE process without lpthreads. I have have had between 1500- 1600 E-Mail 
users on the system at any one time. At certain times, most likely peak times, 
I get the above error (request_module (net-pf-10) ) what does it mean and how 
can I overcome it ?
Comment 13 Arjan van de Ven 2002-11-04 15:59:17 EST
(net-pf-10) is IPv6 (the next generation internet protocol with bigger addresses)

While our kernels support ipv6 as a loadable module, I really doubt you want
this in your setup. You can disable this message by putting
alias net-pf-10 off
in /etc/modules.conf
Comment 14 william ewing 2002-11-06 04:05:01 EST
Thanks, I have made the change to the modules.conf file but how to I invoke it ?
Do I need to reboot ?
Comment 15 Arjan van de Ven 2002-11-06 04:56:24 EST
it's supposed to be immediate
if it's not then I'll check more
Comment 16 william ewing 2002-12-12 03:40:46 EST
I have rebooted the server but I am still getting the same error. Below is a 
copy of my modules.conf
alias eth0 eepro100
alias eth1 eepro100
alias eth2 eepro100
alias scsi_hostadapter aic7xxx
alias scsi_hostadapter2 cciss
alias parport_lowlevel parport_pc
alias usb-controller usb-ohci
alias net-pf-10 off  
Is this ok ?

Any other suggestions ?
Comment 17 Arjan van de Ven 2002-12-12 03:52:34 EST
well modprobe ipv6 will work ;(
Comment 18 Arjan van de Ven 2002-12-12 03:54:54 EST
(note of warning: if you do that and you have a firewall on the machine you also
must set up ipv6 based firewall rules probably)
Comment 19 william ewing 2002-12-14 16:34:16 EST
Any other thoughts on stopping the
request module failure ?

Comment 20 Alan Cox 2002-12-14 19:48:20 EST
Ok the fork failed is it trying to start a new process and failing because you
have the maximum processes allowed running. That is logged and occurs before it
can find out that ipv6 is off anyway.

You could up the max processes with sysctl I guess
Comment 21 william ewing 2002-12-16 07:26:53 EST
I have ran sysctl -A and there are alot of entries . which one would I need to 
change ? and should I increase it by 10%, 50% , 100% ....
Comment 22 william ewing 2002-12-19 05:42:34 EST
Just checking again on now to use the sysctl to max the processes
Comment 23 william ewing 2003-01-15 07:29:24 EST
Please you please give me a hint on how to use sysctl to increase the number of 
Processes
Comment 24 Bugzilla owner 2004-09-30 11:39:55 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.