Bug 737191 - GWT/JavaScript "script too large" error on group Monitoring>Traits subtab for compat group with 1000 or so members and 5 trait defs
GWT/JavaScript "script too large" error on group Monitoring>Traits subtab for...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.1
Unspecified Unspecified
high Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
Mike Foley
:
Depends On:
Blocks: rhq-perf jon30-perf
  Show dependency treegraph
 
Reported: 2011-09-09 16:43 EDT by Ian Springer
Modified: 2013-08-05 20:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:28:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2011-09-09 16:43:43 EDT
The error occurred when I quickly scrolled down to the bottom of the listgrid, causing the datasource to try to fetch hundreds of new rows. I suspect the problem is that the RPC response that was returned was larger than Firefox allows. Here's the exception:

Message :	
Failed to fetch traits for criteria [org.rhq.core.domain.criteria.MeasurementDataTraitCriteria@455].
Severity :	
Error
	
Time :	
Friday, September 9, 2011 4:33:05 PM Etc/GMT+4
Detail :	
com.google.gwt.core.client.JavaScriptException:(InternalError): script too large fileName: http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/04B22DC4ACEBF669E5EAF229B9443CEB.cache.html stack: com_google_gwt_user_client_rpc_impl_ClientSerializationStreamReader_eval__Ljava_lang_String_2Lcom_google_gwt_core_client_JavaScriptObject_2( lineNumber: 14542
--- STACK TRACE FOLLOWS ---
(InternalError): script too large fileName: http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/04B22DC4ACEBF669E5EAF229B9443CEB.cache.html stack: com_google_gwt_user_client_rpc_impl_ClientSerializationStreamReader_eval__Ljava_lang_String_2Lcom_google_gwt_core_client_JavaScriptObject_2( lineNumber: 14542
    at Unknown.com_google_gwt_user_client_rpc_impl_ClientSerializationStreamReader_eval__Ljava_lang_String_2Lcom_google_gwt_core_client_JavaScriptObject_2(Unknown source:0)
Comment 1 Ian Springer 2011-10-17 11:54:36 EDT
This was happening because the groups trait view was grouping by the trait name column, resulting in the ListGrid trying to fetch the entire data set (ListGrid can only perform grouping when all the data is client-side). [master 71f1391] (http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commit;h=71f1391) stops doing the grouping. Now we should only fetch 50 traits at a time (i.e. one page of data).
Comment 2 Mike Foley 2011-10-18 11:15:22 EDT
verified basic functionality
Comment 3 Mike Foley 2012-02-07 14:28:51 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.