Bug 737195 - Provide native systemd service files
Summary: Provide native systemd service files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vtun
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gabriel Somlo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-09 21:15 UTC by Jóhann B. Guðmundsson
Modified: 2011-09-30 19:19 UTC (History)
1 user (show)

Fixed In Version: vtun-3.0.1-12.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-30 19:19:47 UTC


Attachments (Terms of Use)
vtun socket (117 bytes, text/plain)
2011-09-09 21:16 UTC, Jóhann B. Guðmundsson
no flags Details
vtun service (140 bytes, text/plain)
2011-09-09 21:17 UTC, Jóhann B. Guðmundsson
no flags Details

Description Jóhann B. Guðmundsson 2011-09-09 21:15:06 UTC
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jóhann B. Guðmundsson 2011-09-09 21:16:11 UTC
Created attachment 522405 [details]
vtun socket

Comment 2 Jóhann B. Guðmundsson 2011-09-09 21:17:00 UTC
Created attachment 522406 [details]
vtun service

Comment 3 Jóhann B. Guðmundsson 2011-09-09 21:18:18 UTC
Passes simple telnet test

[root@localhost system]# systemctl start vtun.socket
[root@localhost system]# systemctl status vtun.socket
vtun.socket - Vtun Activation Socket
	  Loaded: loaded (/lib/systemd/system/vtun.socket; disabled)
	  Active: active (listening) since Fri, 09 Sep 2011 21:13:30 +0000; 5s ago
	Accepted: 0; Connected: 0
	  CGroup: name=systemd:/system/vtun.socket
[root@localhost system]# telnet localhost 5000
Trying ::1...
Connected to localhost.
Escape character is '^]'.
VTUN server ver 3.X 02/08/2011
ERR
Connection closed by foreign host.


And note there is still a (tight) window to have this in F16

Comment 4 Fedora Update System 2011-09-10 14:19:57 UTC
vtun-3.0.1-11.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/vtun-3.0.1-11.fc16

Comment 5 Jóhann B. Guðmundsson 2011-09-10 14:54:58 UTC
Note that legacy sysv init script should be packed seperatly and propably the legacy init script as well which you to continue to package and ship them ( kinda serves no purpose doing that )

your package should no longer have to depend on xinetd or ship the xinet file.

See for systemd packaging guidelines

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

Comment 6 Jóhann B. Guðmundsson 2011-09-10 14:56:22 UTC
(In reply to comment #5)

I meant the xinetd script should probably be package separately as well

Comment 7 Fedora Update System 2011-09-10 18:58:10 UTC
Package vtun-3.0.1-11.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing vtun-3.0.1-11.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/vtun-3.0.1-11.fc16
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-09-10 22:29:07 UTC
vtun-3.0.1-12.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/vtun-3.0.1-12.fc16

Comment 9 Gabriel Somlo 2011-09-10 22:30:12 UTC
OK, I removed xinetd and sysvinit, let me know if you notice anything still
amiss.

Thx,
--G

Comment 10 Fedora Update System 2011-09-30 19:19:41 UTC
vtun-3.0.1-12.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.