Bug 737207 - Navigation can lead to permission denied if user permissions do not allow access to tab's default url
Summary: Navigation can lead to permission denied if user permissions do not allow acc...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Partha Aji
QA Contact: Katello QA List
URL:
Whiteboard:
: 740967 (view as bug list)
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-09 22:37 UTC by Justin Sherrill
Modified: 2013-03-27 20:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:56:39 UTC


Attachments (Terms of Use)

Description Justin Sherrill 2011-09-09 22:37:36 UTC
How to reproduce:  


Create a user and give him a role that has permissions only to: 

system templates  Read

Log in as that user and go to content management => Permission denied.



Currently navigation.rb only allows a single URL for each main tab, meaning that it won't automatically send the user to the first subtab he has access to.

Comment 1 Mike McCune 2011-09-28 19:37:22 UTC
*** Bug 740967 has been marked as a duplicate of this bug. ***

Comment 3 Mike McCune 2012-01-26 19:08:29 UTC
mass ON_QA move

Comment 5 Corey Welton 2012-02-14 13:36:32 UTC
QA Verified.


Note You need to log in before you can comment on or make changes to this bug.