Bug 737233 - Detect if it's a VM install and enable/ask the user to enable VM-specific optimizations
Summary: Detect if it's a VM install and enable/ask the user to enable VM-specific opt...
Keywords:
Status: CLOSED DUPLICATE of bug 884385
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 7.2
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-10 08:00 UTC by Amit Shah
Modified: 2015-08-28 18:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-28 18:21:23 UTC


Attachments (Terms of Use)

Description Amit Shah 2011-09-10 08:00:41 UTC
Description of problem:
Anaconda can detect whether the installation is being made in a VM.  If it is a VM, some hypervisor-specific and hypervisor-agnostic optimizations can be made for the guest OS, like:
 - Use the 'deadline' IO scheduler instead of the default CFQ
 - Disable suspend-to-ram for the system, as it doesn't result in much benefit in a virt environment

These options could be presented to the user to enable them if they wish.  The installer could then modify the grub parameters or ktune according to the settings chosen.

These options could be exposed for non-virt usage as well, so that admins can tune their systems at install-time or set the parameters in the kickstart file itself.

Comment 4 Brian Lane 2015-08-12 00:48:19 UTC
This is handled automatically by the fix for bug 884385, it detect virtualization and installs packages from a group named "platform-" + the output from systemd-detect-virt

Comment 5 David Cantrell 2015-08-28 18:21:23 UTC

*** This bug has been marked as a duplicate of bug 884385 ***


Note You need to log in before you can comment on or make changes to this bug.