Bug 737238 - [abrt] telepathy-butterfly-0.5.15-3.fc15: connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/donkishoot_40wanadoo_2efr at 0x2a5af50>
Summary: [abrt] telepathy-butterfly-0.5.15-3.fc15: connmgr.py:65:disconnected:KeyError...
Keywords:
Status: CLOSED DUPLICATE of bug 691209
Alias: None
Product: Fedora
Classification: Fedora
Component: telepathy-butterfly
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7ebf97eab492982da4fb37b953e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-10 10:01 UTC by Marcel
Modified: 2011-11-20 14:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-20 14:40:08 UTC


Attachments (Terms of Use)

Description Marcel 2011-09-10 10:01:12 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        /usr/bin/python /usr/libexec/telepathy-butterfly
comment:        maybe network outage
component:      telepathy-butterfly
executable:     /usr/libexec/telepathy-butterfly
kernel:         2.6.40.4-5.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        telepathy-butterfly-0.5.15-3.fc15
reason:         connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/donkishoot_40wanadoo_2efr at 0x2a5af50>
time:           Sat Sep 10 11:50:31 2011
uid:            500

backtrace:
:connmgr.py:65:disconnected:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/t_40wanadoo_2efr at 0x2a5af50>
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 425, in disconnected
:    self._state = ClientState.CLOSED
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 319, in fset
:    self._dispatch("on_client_state_changed", state)
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 44, in _dispatch
:    if event_handler._dispatch_event(name, *args):
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 65, in _dispatch_event
:    handler(*params)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 393, in on_client_state_changed
:    self._disconnected()
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 286, in _disconnected
:    self._manager.disconnected(self)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection_manager.py", line 51, in disconnected
:    result = telepathy.server.ConnectionManager.disconnected(self, conn)
:  File "/usr/lib/python2.7/site-packages/telepathy/server/connmgr.py", line 65, in disconnected
:    self._connections.remove(conn)
:KeyError: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/t_40wanadoo_2efr at 0x2a5af50>
:
:Local variables in innermost frame:
:self: <butterfly.connection_manager.ButterflyConnectionManager at /org/freedesktop/Telepathy/ConnectionManager/butterfly at 0x2a5ab10>
:conn: <butterfly.connection.ButterflyConnection at /org/freedesktop/Telepathy/Connection/butterfly/msn/t_40wanadoo_2efr at 0x2a5af50>

Comment 1 Brian Pepple 2011-11-20 14:40:08 UTC

*** This bug has been marked as a duplicate of bug 691209 ***


Note You need to log in before you can comment on or make changes to this bug.