Bug 737297 - Help not working in QtOctave with Octave >= 3.4.0
Summary: Help not working in QtOctave with Octave >= 3.4.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qtoctave
Version: 15
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-10 20:22 UTC by TNO-reg
Modified: 2011-10-09 19:33 UTC (History)
3 users (show)

Fixed In Version: qtoctave-0.10.1-7.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-09 06:57:44 UTC


Attachments (Terms of Use)

Description TNO-reg 2011-09-10 20:22:46 UTC
Description of problem:

It is impossible to view Octave help via QtOctave graphical interface now for some reason.

Version-Release number of selected component (if applicable): 0.10.1-3.fc15


How reproducible: always


Steps to Reproduce:
1. Press F1 or select 'Help --> Octave help'
  
Actual results:

The help window does not show up. The Octave Terminal window in QtOctave reads the following:

>>> qtinfo
Starting info: qtoctave-info-reader /usr/share/info/octave.info > /dev/null
>>>error: system: can't return output from commands run asynchronously
error: called from:
error:   /usr/share/qtoctave/scripts_octave/qtinfo.m at line 4, column 2

Expected results: Well, obviously the help must work as it used to do.

Additional info:

Comment 1 Kevin Kofler 2011-09-10 21:06:14 UTC
Looks like this stopped working with the latest version of Octave. :-(

Unfortunately, QtOctave upstream is no longer active, so I'm not sure when and even if we can fix this.

Comment 2 Kevin Kofler 2011-10-06 22:47:27 UTC
So actually, the problem there is quite obvious:
system(command, 1, "async");
in qtinfo.m makes no sense. We can't return the stdout of a command run asynchronously, because we return before any stdout is produced. Apparently old versions of Octave didn't complain about this, but the current one does. In this case, stdout is piped to /dev/null anyway, so the argument to return stdout is just nonsense. I'm changing this to:
system(command, 0, "async");

Comment 3 Fedora Update System 2011-10-06 23:50:03 UTC
qtoctave-0.10.1-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/qtoctave-0.10.1-7.fc16

Comment 4 Fedora Update System 2011-10-06 23:50:43 UTC
qtoctave-0.10.1-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/qtoctave-0.10.1-7.fc15

Comment 5 Fedora Update System 2011-10-06 23:52:25 UTC
qtoctave-0.10.1-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qtoctave-0.10.1-7.fc14

Comment 6 Kevin Kofler 2011-10-07 17:17:49 UTC
So it looks like this only affects Octave >= 3.4.0. In particular, Fedora 14 with Octave 3.2.4 shouldn't be affected unless you're using a newer Octave. (It is possible to configure QtOctave to use an Octave binary in a non-default location.)

But in any case, the fix is trivial (1 character) and already queued to stable.

Comment 7 Fedora Update System 2011-10-09 06:56:54 UTC
qtoctave-0.10.1-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-10-09 06:57:44 UTC
qtoctave-0.10.1-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-10-09 19:33:46 UTC
qtoctave-0.10.1-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.