Bug 73730 - Machine crashes while logging out of X-windows
Machine crashes while logging out of X-windows
Status: CLOSED DUPLICATE of bug 73733
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-09 13:39 EDT by Cushing Whitney
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-09 14:08:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cushing Whitney 2002-09-09 13:39:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
When I choose Logout from the gnome system menu, the screen goes blank. I can
telnet into the system, but most commands freeze as does any attempt to reboot
or shutdown the system. On reboot, my system log shows the following:

Sep  9 11:46:39 server kernel: ------------[ cut here ]------------
Sep  9 11:46:39 server kernel: kernel BUG at page_alloc.c:131!
Sep  9 11:46:39 server kernel: invalid operand: 0000
Sep  9 11:46:39 server kernel: CPU:    1
Sep  9 11:46:39 server kernel: EIP:    0010:[__free_pages_ok+282/784]    Tainted: PF
Sep  9 11:46:39 server kernel: EIP:    0010:[<c013975a>]    Tainted: PF
Sep  9 11:46:39 server kernel: EFLAGS: 00013286
Sep  9 11:46:39 server kernel: 
Sep  9 11:46:39 server kernel: EIP is at __free_pages_ok [kernel] 0x11a
(2.4.18-3smp)
Sep  9 11:46:39 server kernel: eax: 00000020   ebx: c156cec8   ecx: c02eee60  
edx: 0001bb17
Sep  9 11:46:39 server kernel: esi: 00000000   edi: c1000030   ebp: 00000000  
esp: d978de90
Sep  9 11:46:39 server kernel: ds: 0018   es: 0018   ss: 0018
Sep  9 11:46:39 server kernel: Process X (pid: 2105, stackpage=d978d000)
Sep  9 11:46:39 server kernel: Stack: c0245b67 00000083 c0399378 c156cec8
00000000 00000001 c156cec8 18cd5067 
Sep  9 11:46:39 server kernel:        c156cec8 c0374d40 18cd5067 00001000
d8d067d4 c012b74e c156cec8 00001000 
Sep  9 11:46:39 server kernel:        00000001 00000000 00000000 415f6000
d978b414 415f5000 c0374d40 00000000 
Sep  9 11:46:39 server kernel: Call Trace: [do_zap_page_range+510/976]
do_zap_page_range [kernel] 0x1fe 
Sep  9 11:46:39 server kernel: Call Trace: [<c012b74e>] do_zap_page_range
[kernel] 0x1fe 
Sep  9 11:46:39 server kernel: [zap_page_range+80/128] zap_page_range [kernel] 0x50 
Sep  9 11:46:39 server kernel: [<c012bdc0>] zap_page_range [kernel] 0x50 
Sep  9 11:46:39 server kernel: [do_munmap+513/672] do_munmap [kernel] 0x201 
Sep  9 11:46:39 server kernel: [<c012e571>] do_munmap [kernel] 0x201 
Sep  9 11:46:39 server kernel: [sys_munmap+53/96] sys_munmap [kernel] 0x35 
Sep  9 11:46:39 server kernel: [<c012e645>] sys_munmap [kernel] 0x35 
Sep  9 11:46:39 server kernel: [system_call+51/56] system_call [kernel] 0x33 
Sep  9 11:46:39 server kernel: [<c0108c6b>] system_call [kernel] 0x33 
Sep  9 11:46:39 server kernel: 
Sep  9 11:46:40 server kernel: 
Sep  9 11:46:40 server kernel: Code: 0f 0b 5f 5d c6 43 24 05 8b 43 18 89 f1 89
dd 83 e0 eb 89 43 



Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Start X-Windows
2. Logout
3. machine freezes
	

Additional info:

My machine is a Dell Precision 410. Dual P-II 450's. The video card in an Nvidia
TNT. Most of the system is stock redhat 7.3. The only major upgrade is the
installation of Ximian Gnome.
Comment 1 Arjan van de Ven 2002-09-09 13:54:45 EDT
Are you using the nvidia binary only kernel modules?
Also for which modules are you using insmod -f ?
Comment 2 Cushing Whitney 2002-09-09 14:08:20 EDT
I am running the binary only modules. The RPMs installed were:

NVIDIA_kernel-1.0-2960.rh73smp
NVIDIA_GLX-1.0-2960

I'm using -F for the i2c-piix4 module so that I can access the tempature sensors
in my machine. The operative line from my /etc/rc.local file is:

modprobe i2c-piix4 force_addr=0x6000

If this might be related, I can disable it.
Comment 3 Arjan van de Ven 2002-09-09 14:19:09 EDT

*** This bug has been marked as a duplicate of 73733 ***

Note You need to log in before you can comment on or make changes to this bug.