Bug 737302 - [abrt] python-setuptools-0.6.14-3.fc14: bdist_egg.py:519:visit:TypeError: 'instancemethod' object is not iterable
Summary: [abrt] python-setuptools-0.6.14-3.fc14: bdist_egg.py:519:visit:TypeError: 'in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-setuptools
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Toshio Ernie Kuratomi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1f57c39f
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-10 21:30 UTC by Tobias Mueller
Modified: 2011-10-18 22:12 UTC (History)
3 users (show)

Fixed In Version: python-setuptools-0.6.21-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-18 22:08:48 UTC


Attachments (Terms of Use)
File: backtrace (3.21 KB, text/plain)
2011-09-10 21:30 UTC, Tobias Mueller
no flags Details

Description Tobias Mueller 2011-09-10 21:30:38 UTC
abrt version: 1.1.18
architecture: x86_64
Attached file: backtrace, 3290 bytes
component: python-setuptools
executable: /usr/bin/easy_install
kernel: 2.6.35.13-92.fc14.x86_64
package: python-setuptools-0.6.14-3.fc14
reason: bdist_egg.py:519:visit:TypeError: 'instancemethod' object is not iterable
release: Fedora release 14 (Laughlin)
time: 1314959667
uid: 1000

How to reproduce
-----
1. apparently I tried to install some package.
2.
3.

Comment 1 Tobias Mueller 2011-09-10 21:30:41 UTC
Created attachment 522549 [details]
File: backtrace

Comment 2 Tobias Mueller 2011-10-08 21:46:03 UTC
Package: python-setuptools-0.6.14-3.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. just ran easy_install -n
2.
3.

Comment 3 Toshio Ernie Kuratomi 2011-10-08 22:33:42 UTC
I can't reproduce.  Are you able to reproduce on a different machine?  Is there some other commandline switch that you're giving easy_install?  What version of python do you have installed?  Does rpm -V python-setuptools and rpm -V python python-libs  all come back with no reported problems?

$ easy_install -n
install_dir /usr/lib/python2.7/site-packages/
error: can't create or remove files in install directory

The following error occurred while trying to add or remove files in the
installation directory:

    [Errno 13] Permission denied: '/usr/lib/python2.7/site-packages/test-easy-install-8500.write-test'

The installation directory you specified (via --install-dir, --prefix, or
the distutils default setting) was:

    /usr/lib/python2.7/site-packages/

Perhaps your account does not have write access to this directory?  If the
installation directory is a system-owned directory, you may need to sign in
as the administrator or "root" account.  If you do not have administrative
access to this machine, you may wish to choose a different installation
directory, preferably one that is listed in your PYTHONPATH environment
variable.

For information on other options, you may wish to consult the
documentation at:

  http://packages.python.org/distribute/easy_install.html

Please make the appropriate changes for your system and try again.

[pts/3@unaka:programming/raffle]$ sudo easy_install -n
[sudo] password for badger: 
install_dir /usr/lib/python2.7/site-packages/
error: No urls, filenames, or requirements specified (see --help)
[pts/3@unaka:programming/raffle]$ sudo easy_install -n kitchen
install_dir /usr/lib/python2.7/site-packages/
Searching for kitchen
Best match: kitchen 1.0.0
Adding kitchen 1.0.0 to easy-install.pth file

Using /usr/lib/python2.7/site-packages
Processing dependencies for kitchen
Finished processing dependencies for kitchen
[pts/3@unaka:programming/raffle]$

Comment 4 Toshio Ernie Kuratomi 2011-10-08 22:52:57 UTC
I see reference to bsddb3 in the backtrace.  Doing easy_install -n bsddb3 reproduces the backtrace.  I think that there's a typo of a variable name in the bdist_egg.py file.  Looks like it was fixed in 0.6.15::

------
0.6.15
------

* Fixed typo in bdist_egg
* Several issues under Python 3 has been solved.
* Issue 146: Fixed missing DLL files after easy_install of windows exe package.

I'll update to the latest upstream version.

Comment 5 Fedora Update System 2011-10-09 06:08:01 UTC
python-setuptools-0.6.21-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/python-setuptools-0.6.21-1.fc14

Comment 6 Fedora Update System 2011-10-09 06:08:10 UTC
python-setuptools-0.6.21-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/python-setuptools-0.6.21-1.fc15

Comment 7 Toshio Ernie Kuratomi 2011-10-09 06:10:49 UTC
If you could test this update to make sure it fixes your issue without regressions (either when it pushes to testing or by downloading the build linked from the update) that would be great.  thanks!

Comment 8 Fedora Update System 2011-10-10 02:50:09 UTC
Package python-setuptools-0.6.21-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-setuptools-0.6.21-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14088
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2011-10-18 22:08:48 UTC
python-setuptools-0.6.21-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-10-18 22:12:11 UTC
python-setuptools-0.6.21-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.