Bug 737317 - Cannot enter data in decision table (Web editor) in 5.2.0 ER3
Summary: Cannot enter data in decision table (Web editor) in 5.2.0 ER3
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: BRM (Guvnor)
Version: BRMS 5.2.0-ER1
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Tihomir Surdilovic
QA Contact: Lukáš Petrovický
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-11 03:24 UTC by Jeff Slone
Modified: 2011-09-15 05:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-14 20:13:57 UTC
Type: ---


Attachments (Terms of Use)
Screenshot showing what double-clicking a cell in the table does... (18.97 KB, image/png)
2011-09-11 03:24 UTC, Jeff Slone
no flags Details

Description Jeff Slone 2011-09-11 03:24:10 UTC
Created attachment 522573 [details]
Screenshot showing what double-clicking a cell in the table does...

Description of problem:
I have created a decision table using the Guvnor guided editor. After creating the column configuration, I set about to enter the rule data in the table. According to the documentation: "Individual cells can be double-clicked and a pop-up editor corresponding to the underlying data-type will appear."

In BRMS 5.2.0 ER3, double-clicking the table cell places a sorting arrow in the cell. You cannot actually enter any data.

Version-Release number of selected component (if applicable):
5.2.0 ER3

How reproducible:
Always

Steps to Reproduce:
1. Create a decision table using the Guvnor guided editor.
2. Configure your condition and action columns.
3. When you're ready to enter data in the table, double-click one of the cells in the table. A sorting arrow is placed in the cell and data cannot be entered.
  
Actual results:
No data editor dialog appears.

Expected results:
A data editor dialog should launch allowing you to configure data in the decision table.

Additional info:

Comment 1 manstis 2011-09-13 15:01:03 UTC
You need to add rows of data first. I suspect you are clicking in the header (where the "sort" icons reside). There is a "Add row" button on an empty grid; after which rows can be inserted arbitrarily using the "+" icon on the side.

Comment 2 Jeff Slone 2011-09-13 18:00:34 UTC
I posted this to the related bug as well. The add row button does not function either. You cannot add rows nor can you add any data. Please test this. I will post a repo if you need one.

Comment 3 manstis 2011-09-14 07:55:05 UTC
Hi Jeff, (this is a copy of what I added to the related bug) - I re-tried with the 5.2.x branch in github (that I believe Guvnor 5.2 ER3 is based on) and was able to add rows using both the "Add row" button and the "+" symbol in the LHS (once one row has been added). Please can you supply a copy of the test repo you are using - incase there is a bug caused by your particular data? Thanks. Mike

Comment 4 Jeff Slone 2011-09-14 20:13:57 UTC
Apparently this is something specific on my RHEL 6 laptop (video driver, patch version...I don't know). I tested it in the RHEL 5 classroom image and it works fine so I'm closing this.


Note You need to log in before you can comment on or make changes to this bug.