Bug 737321 - ibus-gnome3 IME specific menu could be folded so that the long IME list could be shown
ibus-gnome3 IME specific menu could be folded so that the long IME list could...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-11 02:03 EDT by Parag Nemade
Modified: 2011-12-30 02:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-30 02:11:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
pnemade: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2011-09-11 02:03:26 EDT
Description of problem:
I updates ibus on my f15 and when restarted I see different kind of representation of keymap list.
I was using ibus-1.3.99.20110419-18.fc15.x86_64

Version-Release number of selected component (if applicable):
ibus-1.3.99.20110817-4.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
when clicked on keyboard icon of ibus using left and right mouse keys, I get only keymap list

Expected results:
when clicked on keyboard icon of ibus using left and right mouse keys, I get only keymap list whereas with the right click I should get preference.

Additional info:
This happens only when I am in input mode.
Comment 1 Parag Nemade 2011-09-11 02:11:01 EDT
argh! I can't event scroll down to select keymap listed last in the list.
Comment 2 Parag Nemade 2011-09-11 02:50:54 EDT
another thing observed is that while looking into the listed keymaps, if I press ctrl+space then keymap turns on/off but then UI of keymap listings hangs there. 
so its combination of clicking mouse to see keymap list and same time press keys ctrl and space
Comment 3 fujiwara 2011-09-12 05:21:33 EDT
Sorry, I forgot a surrounding API is changed in ibus 1.3.99.20110817.
It requires to update ibus-m17n.
Is your problem fixed with ibus-m17n-1.3.3-3.fc15?
Comment 4 Parag Nemade 2011-09-12 05:40:40 EDT
I still have problems mentioned above even after I updated to ibus-m17n-1.3.3-3.fc15

Currently I have many keymaps listed in ibus
1) I do not get scroll down to select lowest keymap in the list. (not visible as list is long)

2) Left and Right mouse clicks on ibus keyboard icons give same keymap list.

I am still facing issue from comment#2
Comment 5 Parag Nemade 2011-09-13 23:36:34 EDT
Looks like the problematic package is ibus-gnome3. After installing ibus-gnome3, all the problem started.
Comment 6 fujiwara 2011-09-14 00:01:22 EDT
(In reply to comment #4)
> Currently I have many keymaps listed in ibus
> 1) I do not get scroll down to select lowest keymap in the list. (not visible
> as list is long)

OK, I need to enhance the behavior and IME specific menu items needs to be fold.
However probably I think the priority is low at the moment since the many IMEs could be shown if you disable IME menus with Control + Space.

> 2) Left and Right mouse clicks on ibus keyboard icons give same keymap list.

Not a bug for gnome-shell

> I am still facing issue from comment#2

Probably I don't understand your hang in 'UI of keymap listings hangs
there'.
Currently the IME menus need to be closed by mouse in gnome-shell so that gnome-shell doesn't change the input focus.
I think the manual operation will be revised in the future Fedora.
Comment 7 Pravin Satpute 2011-09-14 02:05:40 EDT
(In reply to comment #6)
> (In reply to comment #4)
> > Currently I have many keymaps listed in ibus
> > 1) I do not get scroll down to select lowest keymap in the list. (not visible
> > as list is long)
> 
> OK, I need to enhance the behavior and IME specific menu items needs to be
> fold.
> However probably I think the priority is low at the moment since the many IMEs
> could be shown if you disable IME menus with Control + Space.
> 
> > 2) Left and Right mouse clicks on ibus keyboard icons give same keymap list.
> 
> Not a bug for gnome-shell
> 

Yeah, looking at the behaviour of other icons in panel Netword/Accessibility/Volume control all giving same behaviour for Left and Right key.
Comment 8 fujiwara 2011-12-30 02:11:41 EST
Now the IME selection is moved to top on ibus menu and the enhancement of IME menu could be handled by each IME.
Closing this bug. Probably I don't enhance f15 to minimize the risk.

Note You need to log in before you can comment on or make changes to this bug.