Bug 737329 - Connect storage pool with inaccessible master domain should raise StoragePoolMasterNotFound
Summary: Connect storage pool with inaccessible master domain should raise StoragePool...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Eduardo Warszawski
QA Contact: Daniel Paikov
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-11 07:18 UTC by Igor Lvovsky
Modified: 2013-07-04 07:50 UTC (History)
7 users (show)

Fixed In Version: vdsm-4.9-101
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 07:28:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1782 normal SHIPPED_LIVE new packages: vdsm 2011-12-06 11:55:51 UTC

Description Igor Lvovsky 2011-09-11 07:18:28 UTC
Description of problem:
If during connectStoragePool master domain not found we should return StoragePoolMasterNotFound and not "Domain does not exists"

Version-Release number of selected component (if applicable):


How reproducible:
always on NFS

Steps to Reproduce:
1. connect storage pool with 2 data domains on different storage servers
2. block master domain with iptables 
3. 
  
Actual results:
1. vdsm will restart itself.
2. RHEV-M will try connectStoragePool with inaccessible master
3. vdsm return "domain does not exists"
4. RHEV-M will run step 2 several times untill it decide to run reconstructMaster

Expected results:
1. vdsm will restart itself.
2. RHEV-M will try connectStoragePool with inaccessible master
3. vdsm return StoragePoolMasterNotFound 
4. RHEV-M will run reconstructMaster



Additional info:

Comment 1 Dan Kenigsberg 2011-09-11 07:33:03 UTC
http://gerrit.usersys.redhat.com/903

Comment 4 Daniel Paikov 2011-09-21 09:10:41 UTC
Checked on 4.9-104.

Comment 5 errata-xmlrpc 2011-12-06 07:28:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1782.html


Note You need to log in before you can comment on or make changes to this bug.