Bug 737362 - BUG: Bad page map in process yum pte:1c7ad000 pmd:165ec4067: TAINTED -----B
Summary: BUG: Bad page map in process yum pte:1c7ad000 pmd:165ec4067: TAINTED -----B
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:832a5a69e4c12298dc00c8f5e01...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-11 13:17 UTC by Mark Knoop
Modified: 2012-04-11 14:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-11 14:18:57 UTC


Attachments (Terms of Use)

Description Mark Knoop 2011-09-11 13:17:04 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        ro root=/dev/mapper/System-Root rd_LVM_LV=System/Root rd_LVM_LV=System/Swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_GB.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=uk quiet vga=795 nmi_watchdog=1
comment:        Yum update in screen session over ssh
component:      kernel
kernel:         2.6.40.4-5.fc15.x86_64
kernel_tainted: 32
kernel_tainted_long: System has hit bad_page.
os_release:     Fedora release 15 (Lovelock)
package:        kernel
reason:         [341173.214247] BUG: Bad page map in process yum  pte:1c7ad000 pmd:165ec4067
time:           Sun Sep 11 09:40:11 2011

backtrace:
:[341173.214247] BUG: Bad page map in process yum  pte:1c7ad000 pmd:165ec4067
:[341173.214251] addr:000000000b686000 vm_flags:00100073 anon_vma:ffff88013b0ae0d8 mapping:          (null) index:b686
:[341173.214255] Pid: 26957, comm: yum Tainted: G    B       2.6.40.4-5.fc15.x86_64 #1
:[341173.214258] Call Trace:
:[341173.214262]  [<ffffffff810f6ab8>] print_bad_pte+0x1a3/0x1bc
:[341173.214267]  [<ffffffff810f86a8>] unmap_vmas+0x51e/0x6bd
:[341173.214272]  [<ffffffff810fe0b4>] exit_mmap+0xa8/0x100
:[341173.214277]  [<ffffffff810528b1>] mmput+0x7b/0xe9
:[341173.214281]  [<ffffffff8112c564>] flush_old_exec+0x4b1/0x59d
:[341173.214286]  [<ffffffff81165315>] load_elf_binary+0x2dc/0x175f
:[341173.214291]  [<ffffffff814880e4>] ? _raw_read_lock+0xe/0x10
:[341173.214295]  [<ffffffff81162e68>] ? load_misc_binary+0x79/0x316
:[341173.214300]  [<ffffffff8120cb8c>] ? ima_must_measure+0x14/0x1e
:[341173.214305]  [<ffffffff8120c5a3>] ? process_measurement+0x4f/0xc6
:[341173.214309]  [<ffffffff810e56d2>] ? put_page+0x23/0x33
:[341173.214314]  [<ffffffff8112bf05>] search_binary_handler+0xb3/0x246
:[341173.214319]  [<ffffffff81165039>] ? load_elf_library+0x22f/0x22f
:[341173.214324]  [<ffffffff8112cc93>] do_execve_common+0x192/0x289
:[341173.214328]  [<ffffffff8112cdcd>] do_execve+0x43/0x45
:[341173.214333]  [<ffffffff81010222>] sys_execve+0x43/0x5a
:[341173.214338]  [<ffffffff8148ec9c>] stub_execve+0x6c/0xc0
:[341173.214341] swap_free: Unused swap offset entry 000e3d70
:[341173.214345] BUG: Bad page map in process yum  pte:1c7ae000 pmd:165ec4067
:[341173.214349] addr:000000000b687000 vm_flags:00100073 anon_vma:ffff88013b0ae0d8 mapping:          (null) index:b687
:[341173.214354] Pid: 26957, comm: yum Tainted: G    B       2.6.40.4-5.fc15.x86_64 #1
:[341173.214356] Call Trace:
:[341173.214361]  [<ffffffff810f6ab8>] print_bad_pte+0x1a3/0x1bc
:[341173.214366]  [<ffffffff810f86a8>] unmap_vmas+0x51e/0x6bd
:[341173.214371]  [<ffffffff810fe0b4>] exit_mmap+0xa8/0x100
:[341173.214375]  [<ffffffff810528b1>] mmput+0x7b/0xe9
:[341173.214380]  [<ffffffff8112c564>] flush_old_exec+0x4b1/0x59d
:[341173.214384]  [<ffffffff81165315>] load_elf_binary+0x2dc/0x175f
:[341173.214390]  [<ffffffff814880e4>] ? _raw_read_lock+0xe/0x10
:[341173.214394]  [<ffffffff81162e68>] ? load_misc_binary+0x79/0x316
:[341173.214399]  [<ffffffff8120cb8c>] ? ima_must_measure+0x14/0x1e
:[341173.214404]  [<ffffffff8120c5a3>] ? process_measurement+0x4f/0xc6
:[341173.214408]  [<ffffffff810e56d2>] ? put_page+0x23/0x33
:[341173.214413]  [<ffffffff8112bf05>] search_binary_handler+0xb3/0x246
:[341173.214418]  [<ffffffff81165039>] ? load_elf_library+0x22f/0x22f
:[341173.214423]  [<ffffffff8112cc93>] do_execve_common+0x192/0x289
:[341173.214428]  [<ffffffff8112cdcd>] do_execve+0x43/0x45
:[341173.214432]  [<ffffffff81010222>] sys_execve+0x43/0x5a
:[341173.214437]  [<ffffffff8148ec9c>] stub_execve+0x6c/0xc0

Comment 1 Chuck Ebbert 2011-09-14 09:32:42 UTC
According to this report there were BUGS generated before these. Can you find the first reported one in the logs? (It should say "not tainted" where these say "Tainted: G    B".)

Comment 2 Mark Knoop 2011-09-27 18:57:48 UTC
Sorry for my slow response...

You're right, there were previous soft lockup bugs mainly triggered by rsync, perhaps related to bug 729779. There have been no other bad page map bugs however. 

According to /var/log/messages the previous "not tainted" bug was reported as bug 733608.

Comment 3 Dave Jones 2012-02-21 23:56:17 UTC
[updating multiple bugs at once]

There are a bunch of these 'bad page map' bugs now, and the only thing in common is that they're all on kernels before 3.2 (or 2.6.42 for f15), so I'm optimistic this is fixed in the newest update.

Can you try and reproduce it with the latest update ?

If I don't see any reports from 3.2 in the next week, I'll close these out.

Comment 4 Mark Knoop 2012-02-22 09:36:56 UTC
Yes, I've not seen it since 3.2.


Note You need to log in before you can comment on or make changes to this bug.