Bug 737371 - When upgrading fc15 to fc16-Beta.TC2 update bootloader is not an available option
Summary: When upgrading fc15 to fc16-Beta.TC2 update bootloader is not an available op...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-11 16:44 UTC by Robert Lightfoot
Modified: 2011-09-15 00:20 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-15 00:20:38 UTC


Attachments (Terms of Use)

Description Robert Lightfoot 2011-09-11 16:44:36 UTC
Description of problem:
When upgrading fc15 to fc16-Beta.TC2 update bootloader is not an available option

Version-Release number of selected component (if applicable):
fc16-Beta.TC2

How reproducible:
Every time

Steps to Reproduce:
1. Run FC16 Installer to upgrade fc15 system
2. Update bootloader will be greyed out
3.
  
Actual results:
Update bootloader will be greyed out

Expected results:
Update bootloader is available option and works as in previous versions

Additional info:

Comment 1 Adam Williamson 2011-09-12 19:48:43 UTC
I believe this is intentional, due to the grub -> grub2 switch: I think the option that's expected to be used is 'Create new boot loader configuration'.

Comment 2 Adam Williamson 2011-09-13 01:30:32 UTC
We don't have another blocker review till Friday but we need to decide on blocker status of all uncertain bugs by tomorrow, so can people please vote here?

Comment 3 Adam Williamson 2011-09-13 01:31:58 UTC
I vote -1 blocker -1 nth on this, assuming we fix the key issues in https://bugzilla.redhat.com/show_bug.cgi?id=735730 . What's key is that the default option run on upgrade more or less works. We can except this test case for the F16 release. The reason this option does not exist is the grub->grub2 migration, I believe. I suspect the right resolution is actually NOTABUG.

Comment 4 Robert Lightfoot 2011-09-13 19:51:14 UTC
IF the intent is to force users to New Bootloader then greying out update option makes sense to me also.  But as Adam states 735730 "New Bootloader Option" must work.  -1 Block, -1 NTH


Note You need to log in before you can comment on or make changes to this bug.