Bug 737417 - Qt printer configuration dialog is unresponsive under GNOME 3
Qt printer configuration dialog is unresponsive under GNOME 3
Status: CLOSED DUPLICATE of bug 742658
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-11 18:45 EDT by Tom Horsley
Modified: 2011-09-30 21:29 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 21:29:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2011-09-11 18:45:38 EDT
Description of problem:

On fedora 16 x86_64, installed from the TC2 Beta DVD and updated to
install lots of devel packages and wot-not.

I am running a gnome 3 session, never having logged in to a KDE session
since the install. I build my "kewpie" program, which is written in the Qt
toolkit and available here:

http://home.comcast.net/~tomhorsley/software/kewpie/kewpie.html

I try to run it, and the "config printer" dialog is totally non responsive.
Even the "Cancel" button won't work.

I try logging out and back into a KDE session, and run the same executable,
and the config printer dialog works fine. I run "save config", and I get
the annoying KDE file dialog I always incorrectly double click in.

Something seems to have tied the Qt developement libs to KDE. This is
totally broken, especially the part about them not working unless
you are logged into a KDE session.

I develop software in Qt for a lot of reasons, but none of those reasons
include making it impossible to use my software without also using the
rest of KDE.

Make it stop!

Version-Release number of selected component (if applicable):
qt-devel-4.8.0-0.9.beta1.fc16.x86_64

How reproducible:
every time

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
impossible to run Qt program outside of KDE

Expected results:
able to run my program

Additional info:
Comment 1 Kevin Kofler 2011-09-11 19:08:26 EDT
The qt4 package has been obsolete for years (ever since Qt 4 has become the default version of Qt), bugs must be filed against qt instead. Reassigning.
Comment 2 Kevin Kofler 2011-09-11 19:15:22 EDT
So to address your actual issue:

First of all, nobody is "tying Qt to KDE". (In fact, even kdelibs apps are supposed to work just fine outside of the KDE Plasma workspaces. But Qt also doesn't require kdelibs.)

Your concrete issue appears to be with the "config printer" dialog hanging up. So please report that as the bug it is. Vague complaints like "Qt has become impossible to use outside of KDE" are NOT helpful. (And FYI, the workspace is not called just "KDE" anymore, but "KDE Plasma workspaces" or specifically the "KDE Plasma Desktop workspace".)
Comment 3 Tom Horsley 2011-09-11 20:15:47 EDT
Actually, they are tying Qt to KDE. I also get the KDE file browser when
I try to load or save, and it is also non-functional unless I'm in a
KDE Plasma Desktop workspace session :-). If I just got the native Qt
file browser (which I always have had in fedora releases through f15),
then the file browser would work fine. I have no idea how many other
standard dialogs also don't work in a gnome session.
Comment 4 Kevin Kofler 2011-09-11 20:37:45 EDT
> I also get the KDE file browser when I try to load or save,

That's another bug.

> and it is also non-functional unless I'm in a KDE Plasma Desktop workspace
> session :-).

And that's yet another bug, unless what you're seeing is a general bug affecting ALL Qt dialogs. (The KDE libraries don't provide their own print dialog, so the print dialog is part of Qt, which means the only thing it has in common with the KDE file dialog in kdelibs is pretty much that it is a QDialog. And FWIW, the KDE file dialog is actually a KDialog, which is a subclass of QDialog.)
Comment 5 Kevin Kofler 2011-09-30 21:29:28 EDT
Looks like this is just a special case of bug #742658.

*** This bug has been marked as a duplicate of bug 742658 ***

Note You need to log in before you can comment on or make changes to this bug.