Bug 737433 - keymap names shown are displayed in different ways
Summary: keymap names shown are displayed in different ways
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-12 04:10 UTC by Parag Nemade
Modified: 2011-10-21 07:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-21 07:37:00 UTC


Attachments (Terms of Use)

Description Parag Nemade 2011-09-12 04:10:49 UTC
Description of problem:
after update, old keymap list shows names of keymap in two ways for inscript2 keymaps

some are shown as only their language name like
gu Gujarati
as Assamese

some keymap names
ta Tamil (inscript2 (m17n))
te Telugu (inscript2 (m17n))

Version-Release number of selected component (if applicable):
eekboard-1.0.3-1.fc15.x86_64
m17n-contrib-1.1.12-5.fc15.1.noarch

How reproducible:
always

Steps to Reproduce:
1. 
2.
3.
  
Actual results:
showing different way of inscript2 keymap names

Expected results:
should follow the same naming style for inscript2 keymap names

Additional info:

Comment 1 Daiki Ueno 2011-09-28 09:41:47 UTC
Maybe I don't understand your problem, but assuming that you are talking about the GJS panel provided by ibus-gnome3, isn't it because you have only inscript2 maps enabled for gu/as?  IIUC, the GJS panel omits the IME name if there is only one IME is enabled for a language.

Comment 2 Daiki Ueno 2011-10-12 01:17:28 UTC
Ping?  If it is the case, I'd reassign the component to ibus.

Comment 3 Parag Nemade 2011-10-13 10:00:12 UTC
yes you are right what you said in comment#2. Single keymap if added then no IME name displayed.

Comment 4 fujiwara 2011-10-21 07:37:00 UTC
So can I close this bug? the engine descriptions are shown only when the languages are duplicated as a rule. It's the same implementation of keyboard indicator on gnome-shell.


Note You need to log in before you can comment on or make changes to this bug.