Bug 73747 - kppp/pppd defaultroute problem
kppp/pppd defaultroute problem
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdenetwork (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-09 18:52 EDT by Antonio Vieira
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:18:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonio Vieira 2002-09-09 18:52:56 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux) 
 
Description of problem: 
Machine with eth0 interface fails to change pppd default route using kppp as 
dialer. 
 
I checked the pppd process command line and it's using the defaultroute 
parameter as it should be. 
 
If the eth0 is turned off, it uses ppp0 as route, bypassing the issue. Using 
neat with the same ISP account works just fine, altough I notice it passes a 
lot more parameters to pppd. 
 
 
 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. machine with eth0 interface for internal network (IP: 192.168.0.1 
and default anaconda settings) 
2. eth0 cable unplugged (shounldn't be relevant!) 
3. create a kppp ISP account and dial 
4. pinging any machine (by IP to avoid dns lookup) doesn't work because the 
system keeps using eth0 as route (pinging 'from' shows internal IP).  
 
Additional info:
Comment 1 Gianluca Renzi 2002-12-11 06:15:11 EST
I had the same problem, moving my machine into another network and moving back
again... It seems to be related to eth0 default route. The problem is if I use
/sbin/ifup ppp0 everything is working fine, otherwise with KPPP it doesn't work
at all. Where am I wrong?
Comment 2 Petr Rockai 2006-07-17 14:43:51 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 3 Bill Nottingham 2006-10-18 14:18:23 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.