Bug 737533 - Pulp expects oauth's pulp-user header to contain a valid local username
Summary: Pulp expects oauth's pulp-user header to contain a valid local username
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Pulp
Classification: Retired
Component: user-experience
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: Sprint 29
Assignee: Jason Connor
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-12 13:01 UTC by Dmitri Dolguikh
Modified: 2014-03-31 01:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-26 18:36:39 UTC


Attachments (Terms of Use)

Description Dmitri Dolguikh 2011-09-12 13:01:19 UTC
When oauth is used (or at least when calls to pulp are made by katello), katello performs all authentication/authorization checks, therefore pulp shouldn't expect that the user passed in "pulp-user" header will exist in pulp's user database; this information is passed in mostly for logging purposes.

Comment 1 Dmitri Dolguikh 2011-09-12 13:10:54 UTC
Could whoever picks up this issue contact dmitri@redhat.com / witlessb on #pulp when it's fixed?

Comment 2 Jason Connor 2011-10-26 18:36:39 UTC
Talked to Dmitri: Katello is now creating a Pulp user with the appropriate permissions.

Closing as not a bug


Note You need to log in before you can comment on or make changes to this bug.