Bug 737553 - should not be compliant for a future subscription
should not be compliant for a future subscription
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: John Sefler
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-09-12 10:32 EDT by John Sefler
Modified: 2011-12-06 12:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:24:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sm-gui should NOT show system as compliant when the covering subscription(s) begin inthe future (56.08 KB, image/png)
2011-09-12 10:32 EDT, John Sefler
no flags Details
Certificate Status remains RED even when ALL products are covered by Future Subscriptions - this is correct! (186.07 KB, image/png)
2011-10-02 22:48 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2011-09-12 10:32:59 EDT
Created attachment 522713 [details]
sm-gui should NOT show system as compliant when the covering subscription(s) begin inthe future

Description of problem:
System compliance should be calculated based on today's status, not some date in the future.

Using candlepin with TESTDATA=1 deployed, install only one product cert and then subscribe to a subscription that covers it in the future.  The problem is that compliance is getting reported as green even though we are really not compliant today.

See the attached screenshot. and follow the recreate steps.

Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-0.96.9-1.git.10.adab5e3.el6.x86_64
subscription-manager-gnome-0.96.9-1.git.10.adab5e3.el6.x86_64
subscription-manager-0.96.9-1.git.10.adab5e3.el6.x86_64
[root@jsefler-onprem-62server ~]# rpm -q python-rhsm
python-rhsm-0.96.11-1.git.8.7061b8a.el6.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password --org=admin
The system has been registered with id: c5f57b72-19b0-4b5a-8cef-6f7dfe94c960 
[root@jsefler-onprem-62server ~]# ls /etc/pki/product/
37060.pem
[root@jsefler-onprem-62server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Awesome OS Server Bits   
Status:             	Not Subscribed           
Expires:            	                         
SerialNumber:       	                         
ContractNumber:     	                         
AccountNumber:      	                         

[root@jsefler-onprem-62server ~]# subscription-manager facts --list | grep valid
system.entitlements_valid: False

^^^ THAT LOOKS CORRECT, NOW LET'S SUBSCRIBE TO A FUTURE SUBSCRIPTION AVAILABLE ABOUT A YEAR FROM NOW...

[root@jsefler-onprem-62server ~]# date
Mon Sep 12 10:10:20 EDT 2011

[root@jsefler-onprem-62server ~]# subscription-manager list --avail --ondate=2013-01-01 | grep awesomeos-server-basic -A5 -B1
ProductName:       	Awesome OS Server Basic  
ProductId:         	awesomeos-server-basic   
PoolId:            	8a90f8c6324b1fa801324b212dd006a0
Quantity:          	15                       
Multi-Entitlement: 	No                       
Expires:           	08/27/2013               
MachineType:       	physical                 
--
ProductName:       	Awesome OS Server Basic (multi-entitlement)
ProductId:         	awesomeos-server-basic-me
PoolId:            	8a90f8c6324b1fa801324b212d030679
Quantity:          	15                       
Multi-Entitlement: 	Yes                      
Expires:           	08/27/2013               
MachineType:       	physical                 

[root@jsefler-onprem-62server ~]# subscription-manager subscribe --pool=8a90f8c6324b1fa801324b212dd006a0
Successfully subscribed the system to Pool 8a90f8c6324b1fa801324b212dd006a0
[root@jsefler-onprem-62server ~]# subscription-manager list --consumed
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+


ProductName:        	Awesome OS Server Bits   
ContractNumber:     	7                        
AccountNumber:      	12331131231              
SerialNumber:       	5758893397307845501      
Active:             	True                     
QuantityUsed:       	1                        
Begins:             	08/27/2012               
Expires:            	08/27/2013    

[root@jsefler-onprem-62server ~]# subscription-manager facts --list | grep valid
system.entitlements_valid: True

^^^ THAT'S WRONG.  WE SHOULD NOT BE COMPLIANT TODAY FOR A SUBSCRIPTION THAT STARTS IN THE FUTURE ON 08/27/2012

  
See the screenshot of the GUI too
Comment 1 William Poteat 2011-09-28 10:50:11 EDT
Commits:

RHEL6.2: b0f3c343bde5ec0014bf5d8feccbaab44c209b68

Master: 939d471bf19bf6ec07233142ad0145559e63f141
Comment 4 John Sefler 2011-10-02 22:48:40 EDT
Created attachment 525971 [details]
Certificate Status remains RED even when ALL products are covered by Future Subscriptions - this is correct!

Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.11-1.git.21.0fdd5b9.el6.x86_64


With several products installed, I subscribed to future subscriptions that provide coverage for all the installed products.  Despite the complete coverage in the future, the overall system's Certificate Status remains RED - this is correct since the overall status is for today!


[root@jsefler-onprem-62server ~]# date
Sun Oct  2 22:36:13 EDT 2011
[root@jsefler-onprem-62server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Awesome OS for S390 Bits 
Version:            	3.11                     
Arch:               	s390x                    
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Awesome OS Scalable Filesystem Bits
Version:            	1.0                      
Arch:               	ALL                      
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Awesome OS for z80/x86_64 Bits
Version:            	3.11                     
Arch:               	z80,x86_64               
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Awesome OS for x86 Bits  
Version:            	8.6                      
Arch:               	x86                      
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Awesome OS for z80/ALL Bits
Version:            	3.11                     
Arch:               	z80,ALL                  
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Awesome OS for x86_64/ALL Bits
Version:            	3.11                     
Arch:               	x86_64,ALL               
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Awesome OS for x86_64/ALL Bits for ZERO sockets
Version:            	3.11                     
Arch:               	x86_64,ALL               
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Awesome OS for x86/x64_64 Bits
Version:            	8.64                     
Arch:               	x86,x86_64               
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Awesome OS for Intel x86_64/i686/ia64 Bits
Version:            	3.11                     
Arch:               	x86_64,i686,ia64         
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Awesome OS for x86_64/s390x Bits
Version:            	3.11                     
Arch:               	x86_64,s390x             
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Awesome OS Workstation Bits
Version:            	6.1                      
Arch:               	ALL                      
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Awesome OS for x86_64/i686/ia64/ppc/ppc64/s390x/s390 Bits
Version:            	3.11                     
Arch:               	x86_64,i686,ia64,ppc,ppc64,s390x,s390
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Management Bits          
Version:            	1.0                      
Arch:               	ALL                      
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Large File Support Bits  
Version:            	1.0                      
Arch:               	ALL                      
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Awesome OS Modifier Bits 
Version:            	6.1                      
Arch:               	ALL                      
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Clustering Bits          
Version:            	1.0                      
Arch:               	ALL                      
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Shared Storage Bits      
Version:            	1.0                      
Arch:               	ALL                      
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Awesome OS Server Bits   
Version:            	6.1                      
Arch:               	ALL                      
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Load Balancing Bits      
Version:            	1.0                      
Arch:               	ALL                      
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               


ProductName:        	Awesome OS Premium Architecture Bits
Version:            	6.1                      
Arch:               	ppc64                    
Status:             	Future Subscription      
Starts:             	09/19/2012               
Expires:            	09/19/2013               

[root@jsefler-onprem-62server ~]# subscription-manager facts --list | grep valid 
system.entitlements_valid: False
[root@jsefler-onprem-62server ~]# 

Moving to VERIFIED
Comment 5 errata-xmlrpc 2011-12-06 12:24:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.