Bug 737559 - Copying and pasting text from Opera browser to Thunderbird mail compose box does not work
Summary: Copying and pasting text from Opera browser to Thunderbird mail compose box d...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 15
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-12 14:47 UTC by Syam
Modified: 2018-04-11 10:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-24 07:19:28 UTC


Attachments (Terms of Use)

Description Syam 2011-09-12 14:47:57 UTC
Description of problem:

I use Opera browser & Thunderbird on KDE. When I copy some text from Opera (text from a webpage rendered by the browser) and try to paste it in Thunderbird's mail compose window, it doesn't work. Nothing gets pasted.

I know the copying works because I can paste the text successfully on other text-entry boxes in Thunderbird (the address and subject fields of the compose window, the 'search messages' box in the main UI etc.). Also pasting text from Opera works flawlessly on Firefox and other KDE/GNOME applications.

The problem happens only when copying text from Opera. I can successfully paste text copied from Firefox and other KDE/GNOME applications.

The text copied from Opera is displayed by KDE's Klipper application. An interesting observation is that if I simply click on this entry in Klipper's menu and then press Ctrl+V in Thunderbird, the text gets pasted successfully.


Version-Release number of selected component (if applicable):

Thunderbird v6.0.2 (problem has been there with previous versions also)
Opera v11.51
KDE v4.6.5
iBus v1.3.99.20110817 (enabled, but no input methods active)
kernel v2.6.40.4-5.fc15.i686.PAE

Comment 1 Syam 2011-09-19 14:42:57 UTC
New observation:
Pasting the text using Ctrl+Alt+Shift+V works.
Also, right-clicking the composer box and selecting 'Paste without formatting' also works.

Comment 2 Syam 2011-09-19 14:48:45 UTC
Apologies for split comments..
Note:
The observation is same for GNOME & KDE.

Comment 3 Matěj Cepl 2011-09-24 07:19:28 UTC
(In reply to comment #0)
> The problem happens only when copying text from Opera. I can successfully paste
> text copied from Firefox and other KDE/GNOME applications.

We don't support Opera, so unless you are able to show me how to reproduce this bug using only Fedora-provided software, I cannot help you.

I would suspect that Opera is copying into the clipboard something weird instead of text/html, which cannot be deciphered readily by normal X applications.

For the troubleshooting of this issue, it might be helpful to know that DE (I am sure about Gnome ... http://lildude.co.uk/howto-use-xclipboard-with-gnome, but KDE as well, I suppose) take over clipboard management, so for example xclipboard doesn't work in plain Gnome. Maybe that KDE clipboard utilities (is klipper still around?) could help you to investigate what actually is Opera copying to the clipboard.

Anyway, closing as CANTFIX (because we cannot with Fedora-provided software)

Comment 4 Syam 2011-09-26 01:29:05 UTC
(In reply to comment #3)
> We don't support Opera, so unless you are able to show me how to reproduce this
> bug using only Fedora-provided software, I cannot help you.

Well, I do understand the logic of not supporting external software. But doing a search on 'copy paste problem Thunderbird' brings up lots of results. Although most of these are old bugs that are fixed in new versions, they do indicate that Thunderbird has had several problems with pasting text.
So I was thinking this Opera observation could be pointing to some other problem with Thunderbird.


> I would suspect that Opera is copying into the clipboard something weird
> instead of text/html, which cannot be deciphered readily by normal X
> applications.

In that case, in Opera's defense, it must be noted that the problem happens only with Thunderbird.
Pasting works properly with all other GNOME/KDE applications. It even works in other text boxes of Thunderbird, except for the 'compose' box.


> 
> For the troubleshooting of this issue, it might be helpful to know that DE (I
> am sure about Gnome ... 

As I said in comment #2, the problem is on GNOME & KDE. KDE is running Klipper but I don't know what GNOME does for clipboard management.


Note You need to log in before you can comment on or make changes to this bug.