Bug 737642 - changing permission of one file disables drift silently
changing permission of one file disables drift silently
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.1
Unspecified Unspecified
high Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 707225
  Show dependency treegraph
 
Reported: 2011-09-12 15:20 EDT by dgao
Modified: 2012-02-07 14:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:26:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dgao 2011-09-12 15:20:05 EDT
Changing the permission of one file to non-readable would cause drift to stop. This stoppage however does not make it to the user level, but instead it fails silently. 

In addition the entire drift should not stop just because the agent cannot read a single file. Instead it should just skip over that file and continue to detect drift on other readable files.

To reproduce:
- Create a file drift and point to a readable folder
- Create two files in that folder and verify that both files show up in drift history.
- Change permission of one of the file to non-readable state
- Make modification to the other file.
- Verify that no error message occurs in RHQ UI
- Verify that the modification on the second file does not show up on drift history.
Comment 1 John Sanda 2011-10-04 14:26:29 EDT
This is related to and address by the fix for bug 737647
Comment 2 Mike Foley 2011-10-04 16:33:23 EDT
verified 10/4/2011
Comment 3 Mike Foley 2012-02-07 14:26:02 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.