Bug 737680 - Cannot export any database
Summary: Cannot export any database
Keywords:
Status: CLOSED DUPLICATE of bug 730015
Alias: None
Product: Fedora
Classification: Fedora
Component: 389-ds-console
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-12 21:05 UTC by Michael Cronenworth
Modified: 2011-11-07 21:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-24 21:37:11 UTC


Attachments (Terms of Use)
java exception output during export (9.29 KB, text/plain)
2011-09-12 22:16 UTC, Michael Cronenworth
no flags Details

Description Michael Cronenworth 2011-09-12 21:05:37 UTC
Description of problem: I typically export my LDAP database using the 389 console program. With the latest version of 389 I no longer can get a file to export.


Version-Release number of selected component (if applicable):
Client:
$ rpm -qa | grep ^389 | sort
389-admin-1.1.23-1.fc15.x86_64
389-adminutil-1.1.14-1.fc15.x86_64
389-console-1.1.7-1.fc15.noarch
389-ds-base-1.2.9.9-1.fc15.x86_64
389-ds-base-libs-1.2.9.9-1.fc15.x86_64
389-ds-console-1.2.6-1.fc15.noarch

Server:
$ rpm -qa | grep ^389 | sort
389-admin-1.1.23-1.fc14.x86_64
389-admin-console-1.1.8-1.fc14.noarch
389-admin-console-doc-1.1.8-1.fc14.noarch
389-adminutil-1.1.14-1.fc14.x86_64
389-console-1.1.7-1.fc14.noarch
389-ds-1.2.2-1.fc14.noarch
389-ds-base-1.2.9.9-1.fc14.x86_64
389-ds-base-libs-1.2.9.9-1.fc14.x86_64
389-ds-console-1.2.6-1.fc14.noarch
389-ds-console-doc-1.2.6-1.fc14.noarch
389-dsgw-1.1.7-2.fc14.x86_64


How reproducible: Always


Steps to Reproduce:
1. Run 389-console
2. Connect to 389 Admin server
3. Open Directory Server console
4. Click on Export Databases task.
5. Select output file. Any path. (local file system, not NFS)
6. Click OK.
  
Actual results:
Nothing happens.

Expected results:
Creation of file and exported data.

Comment 1 Nathan Kinder 2011-09-12 21:50:27 UTC
Are you running SELinux in enforcing mode?  The SELinux policy will only allow ns-slapd to write the LDIF file to a location that is properly labelled as dirsrv_var_lib_t.  It is intended that you use the /var/lib/dirsrv/slapd-<instance>/ldif directory for exports.

If the problem is not related to SELinux, it would be good to see if there are any errors in your DS errors log when you attempt to export.

Comment 2 Michael Cronenworth 2011-09-12 22:14:41 UTC
Nathan, please re-read my bug report. I am using the console on a remote workstation. Not on the ldap server. I am not using a remote X session. Yes, the server is in enforcing mode. Disabling SELinux does not make a difference.

It appears that a java exception is thrown when I press OK on the Export Databases window. I will attach it.

Please note: This worked great several months ago when I made my last backup. My LDAP server is at least 3 years old now and I have never had this problem before.

Comment 3 Michael Cronenworth 2011-09-12 22:16:17 UTC
Created attachment 522816 [details]
java exception output during export

Exception is thrown when I press "Yes" on the warning window that is presented when I try to export a database on a remote workstation.

Comment 4 Nathan Kinder 2011-10-24 21:17:41 UTC
I believe that this is a bug in java.  In particular, it looks to be the same as bug 730015, which has the same exception.  Try updating your java-1.6.0-openjdk package on the systym that you are running Console on.

Comment 5 Michael Cronenworth 2011-10-24 21:37:11 UTC
Using the latest java package (from October 18th) does indeed fix this issue. Thanks.

*** This bug has been marked as a duplicate of bug 730015 ***


Note You need to log in before you can comment on or make changes to this bug.