Bug 737684 - Software entitlements valid "through" should be "until"
Summary: Software entitlements valid "through" should be "until"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel62 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-12 21:15 UTC by John Sefler
Modified: 2013-01-10 10:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:24:16 UTC


Attachments (Terms of Use)
Software entitlements valid "through" or "until" (285.00 KB, image/png)
2011-09-12 21:15 UTC, John Sefler
no flags Details
until (265.51 KB, image/png)
2011-09-22 19:43 UTC, J.C. Molet
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1695 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2011-12-06 01:23:29 UTC

Description John Sefler 2011-09-12 21:15:53 UTC
Created attachment 522797 [details]
Software entitlements valid "through" or "until"

Description of problem:
The Subscription Assistant displays a summary message called "Software entitlements valid through <date>".  I know we have juggled this wording and the dates multiple times in past defects and I suspect some more code change has regressed the accuracy of this statement.  Looking at the attached screenshot, the circled items in green all appear to support each other while the word "through" circled in red is wrong.  Changing it to "until" would satisfy the rest of the data and the "first date of invalid entitlements".

Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.96.9-1.git.10.adab5e3.el6.x86_64


How reproducible:


Steps to Reproduce:
See screenshot
  
Actual results:
Software entitlements valid through

Expected results:
Software entitlements valid until

Comment 1 James Bowes 2011-09-20 15:44:44 UTC
fixed in RHEL6.2 0764461e627463022c670dad5593e9abc8a10fa3
and master 8e1b17419af61a00cee5d550808bd0314a9b5255

Comment 3 J.C. Molet 2011-09-22 19:43:38 UTC
Created attachment 524462 [details]
until

All dates are displayed now in terms of 'until'.  It is now consistent and makes sense.

Marking VERIFIED.


python-rhsm-0.96.12-1.git.0.4862863.el6.noarch
subscription-manager-firstboot-0.96.11-1.git.1.945da16.el6.x86_64
subscription-manager-0.96.11-1.git.1.945da16.el6.x86_64
subscription-manager-gnome-0.96.11-1.git.1.945da16.el6.x86_64

Comment 4 errata-xmlrpc 2011-12-06 17:24:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html


Note You need to log in before you can comment on or make changes to this bug.