Bug 737695 - Provide native systemd services
Provide native systemd services
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ebnetd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-09-12 18:01 EDT by Jóhann B. Guðmundsson
Modified: 2012-05-26 03:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-24 19:52:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
http socket (125 bytes, text/plain)
2011-09-12 18:02 EDT, Jóhann B. Guðmundsson
no flags Details
http service (164 bytes, text/plain)
2011-09-12 18:02 EDT, Jóhann B. Guðmundsson
no flags Details
ebnetd socket (124 bytes, text/plain)
2011-09-12 18:03 EDT, Jóhann B. Guðmundsson
no flags Details
ebnetd service (159 bytes, text/plain)
2011-09-12 18:04 EDT, Jóhann B. Guðmundsson
no flags Details
ndtpd socket (112 bytes, text/plain)
2011-09-12 18:04 EDT, Jóhann B. Guðmundsson
no flags Details
ndtpd service (158 bytes, text/plain)
2011-09-12 18:06 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-09-12 18:01:24 EDT
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-09-12 18:02:04 EDT
Created attachment 522810 [details]
http socket
Comment 2 Jóhann B. Guðmundsson 2011-09-12 18:02:40 EDT
Created attachment 522811 [details]
http service
Comment 3 Jóhann B. Guðmundsson 2011-09-12 18:03:23 EDT
Created attachment 522812 [details]
ebnetd socket
Comment 4 Jóhann B. Guðmundsson 2011-09-12 18:04:07 EDT
Created attachment 522813 [details]
ebnetd service
Comment 5 Jóhann B. Guðmundsson 2011-09-12 18:04:50 EDT
Created attachment 522814 [details]
ndtpd socket
Comment 6 Jóhann B. Guðmundsson 2011-09-12 18:06:39 EDT
Created attachment 522815 [details]
ndtpd service
Comment 7 Jóhann B. Guðmundsson 2011-09-12 18:07:12 EDT
Once package and shipped your package should no longer have to depend on xinetd

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
Comment 8 Akira TAGOH 2011-09-16 02:44:05 EDT
Thanks for working on this. FWIW is this supposed to be obsolete the xinetd support as well? just wonder if I should get rid of the dependency with it or still keep it.
Comment 9 Jóhann B. Guðmundsson 2011-09-16 15:40:35 EDT
Well you can your component no longer should haver to depend on xinetd since it now ships unit files that do exactly the same thing.

We dont have anykind of policy around migrating from xinetd to systemd but I assume that fpc would be consistent in their work and ask maintainers to package xinetd snippets into an seperated xinet subpackages should they want to continue to ship xinetd snippets as is being done with legacy sysv init scripts.

I also recommend that your rename http unit files to ebhttp to avoid potential conflicts with apache.
Comment 10 Akira TAGOH 2011-09-20 02:06:17 EDT
Okay, thanks. for renaming, I was about to do that.

One more question though, how can I test this if it works as expected?
I tried to do systemctl enable ndtpd.socket and ndtpd.service though, when connecting to the port 2882, it was just refused. and systemctl status ndtpd.socket gives me failed then. systemctl status ndtpd.service also says failed but there are no logs in /var/log/messages systemd brought up the ndtpd daemon at all.

The testing package is available at http://koji.fedoraproject.org/koji/taskinfo?taskID=3354914
Comment 11 Akira TAGOH 2011-11-08 03:08:35 EST
Rereading https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd, and the service file seems missing Wants= line for .socket. however the daemon still not running successfully because of the failure on getpeername().

I'm expecting systemd will invoke the service when the socket is accepted though, as per this behavior, it seems not. any idea to get this working on systemd anyway?
Comment 12 Akira TAGOH 2012-05-14 03:44:35 EDT
Okay, finally I got it. fixed in 1.0-12.fc18
Comment 13 Fedora Update System 2012-05-14 03:57:41 EDT
ebnetd-1.0-12.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ebnetd-1.0-12.fc17
Comment 14 Fedora Update System 2012-05-14 03:59:48 EDT
ebnetd-1.0-12.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ebnetd-1.0-12.fc16
Comment 15 Fedora Update System 2012-05-14 04:06:24 EDT
ebnetd-1.0-12.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ebnetd-1.0-12.fc15
Comment 16 Fedora Update System 2012-05-14 22:33:15 EDT
Package ebnetd-1.0-12.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ebnetd-1.0-12.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7866/ebnetd-1.0-12.fc17
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2012-05-24 19:52:35 EDT
ebnetd-1.0-12.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2012-05-24 19:55:28 EDT
ebnetd-1.0-12.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2012-05-26 03:40:04 EDT
ebnetd-1.0-12.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.