Bug 73774 - default font does not exist
Summary: default font does not exist
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ImageMagick   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-10 17:11 UTC by Florin Andrei
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 04:54:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Florin Andrei 2002-09-10 17:11:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
I'm running gpsmap - the mapping utility included in the Kismet package (see URL
at the end). This tool takes a .png file and adds all kind of comments, labels,
dots, etc. to it.
In order to add labels, it relies on ImageMagick, using the default font that
ImageMagick has predefined. Problem is, the default font is not configured
correctly.
I get this error:

gpsmap: Unable to read font (/usr/share/ghostscript/fonts/n019003l.pfb) [No such
file or directory].

That font does exist on my system, it is included by several different
packages. For example, it is in /usr/share/fonts/default/Type1 as a part of the
urw-fonts package.

So, it's like the path is wrong or something.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.get kismet
2.compile it
3.run gpsmap with the labels option
	

Actual Results:  Labels cannot be added to the map, because ImageMagick cannot
find its default font.

Expected Results:  Labels should be added to the map.

Additional info:

Kismet is here: http://www.kismetwireless.net/
I'm actually using the "devel" version, not the stable one.

Comment 1 Matthias Clasen 2005-04-25 04:54:41 UTC
Should be fixed in FC3/FC4 with 6.2.0.


Note You need to log in before you can comment on or make changes to this bug.