Bug 737746 - WARNING: at drivers/gpu/drm/i915/i915_irq.c:649 ironlake_irq_handler+0xbf0/0xc00 [i915]() (Not tainted)
Summary: WARNING: at drivers/gpu/drm/i915/i915_irq.c:649 ironlake_irq_handler+0xbf0/0x...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 767187
TreeView+ depends on / blocked
 
Reported: 2011-09-13 02:02 UTC by Chao Ye
Modified: 2013-01-10 08:22 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-04 17:57:15 UTC


Attachments (Terms of Use)

Description Chao Ye 2011-09-13 02:02:07 UTC
Description of problem:
vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem 
------------[ cut here ]------------ 
WARNING: at drivers/gpu/drm/i915/i915_irq.c:649 ironlake_irq_handler+0xbf0/0xc00 [i915]() (Not tainted) 
Hardware name: SandyBridge Platform 
Missed a PM interrupt 
Modules linked in: i915(+) snd_pcm snd_seq iwlcore drm_kms_helper firewire_ohci snd_timer snd_seq_device snd_hwdep mac80211 video i2c_algo_bit drm sd_mod sr_mod firewire_core ext4 snd iTCO_wdt i2c_i801 cfg80211 acpi_cpufreq cpufreq_ondemand ata_generic output i2c_core ahci crc_t10dif cdrom crc_itu_t jbd2 mbcache e1000e snd_page_alloc soundcore shpchp iTCO_vendor_support sg microcode rfkill ecb arc4 ipv6 mperf freq_table sunrpc dm_snapshot dm_zero dm_mirror dm_region_hash dm_log dm_mod 
Pid: 285, comm: insmod Not tainted 2.6.32-196.el6.x86_64 #1 
Call Trace: 
 <IRQ>  [<ffffffff81069b17>] ? warn_slowpath_common+0x87/0xc0 
 [<ffffffff81069c06>] ? warn_slowpath_fmt+0x46/0x50 
 [<ffffffffa0339690>] ? ironlake_irq_handler+0xbf0/0xc00 [i915] 
 [<ffffffff81058ebf>] ? scheduler_tick+0xdf/0x290 
 [<ffffffff810d9410>] ? handle_IRQ_event+0x60/0x170 
 [<ffffffff8107215a>] ? __do_softirq+0x11a/0x1d0 
 [<ffffffff810dbb4e>] ? handle_edge_irq+0xde/0x180 
 [<ffffffff8100dec9>] ? handle_irq+0x49/0xa0 
 [<ffffffff814f418c>] ? do_IRQ+0x6c/0xf0 
 [<ffffffff8100ba13>] ? ret_from_intr+0x0/0x11 
 <EOI>  [<ffffffff814ee807>] ? _spin_unlock_irqrestore+0x17/0x20 
 [<ffffffff810da8e4>] ? enable_irq+0x64/0xa0 
 [<ffffffff810dac64>] ? request_threaded_irq+0x1d4/0x2f0 
 [<ffffffffa0338aa0>] ? ironlake_irq_handler+0x0/0xc00 [i915] 
 [<ffffffffa0338aa0>] ? ironlake_irq_handler+0x0/0xc00 [i915] 
 [<ffffffffa0267cf6>] ? drm_irq_install+0x136/0x1e0 [drm] 
 [<ffffffffa0331907>] ? i915_driver_load+0xe07/0x1360 [i915] 
 [<ffffffff8134356e>] ? device_register+0x1e/0x30 
 [<ffffffffa026da26>] ? drm_sysfs_device_add+0x86/0xb0 [drm] 
 [<ffffffffa026a643>] ? drm_get_minor+0x1d3/0x310 [drm] 
 [<ffffffffa026cdef>] ? drm_get_pci_dev+0x19f/0x300 [drm] 
 [<ffffffffa038aa1e>] ? i915_pci_probe+0x20/0x1b0 [i915] 
 [<ffffffff812892a7>] ? local_pci_probe+0x17/0x20 
 [<ffffffff8128a491>] ? pci_device_probe+0x101/0x120 
 [<ffffffff81346102>] ? driver_sysfs_add+0x62/0x90 
 [<ffffffff813462a0>] ? driver_probe_device+0xa0/0x2a0 
 [<ffffffff8134654b>] ? __driver_attach+0xab/0xb0 
 [<ffffffff813464a0>] ? __driver_attach+0x0/0xb0 
 [<ffffffff81345504>] ? bus_for_each_dev+0x64/0x90 
 [<ffffffff8134603e>] ? driver_attach+0x1e/0x20 
 [<ffffffff81345940>] ? bus_add_driver+0x200/0x300 
 [<ffffffff81346876>] ? driver_register+0x76/0x140 
 [<ffffffff810e2bdc>] ? tracepoint_update_probe_range+0xfc/0x130 
 [<ffffffff8128a6f6>] ? __pci_register_driver+0x56/0xd0 
 [<ffffffff814f19c5>] ? notifier_call_chain+0x55/0x80 
 [<ffffffffa03b6000>] ? i915_init+0x0/0x8d [i915] 
 [<ffffffffa026d06a>] ? drm_pci_init+0x11a/0x130 [drm] 
 [<ffffffffa03b6000>] ? i915_init+0x0/0x8d [i915] 
 [<ffffffffa03b608b>] ? i915_init+0x8b/0x8d [i915] 
 [<ffffffff8100204c>] ? do_one_initcall+0x3c/0x1d0 
 [<ffffffff810af5a1>] ? sys_init_module+0xe1/0x250 
 [<ffffffff8100b0b2>] ? system_call_fastpath+0x16/0x1b 
---[ end trace c662cda138f61977 ]--- 
firewire_core: created device fw0: GUID 354fc00035e71a01, S400 
fbcon: inteldrmfb (fb0) is primary device 
Console: switching to colour frame buffer device 128x48 
fb0: inteldrmfb frame buffer device 
drm: registered panic notifier 
Slow work thread pool: Starting up 
Slow work thread pool: Ready 

Version-Release number of selected component (if applicable):
RHEL6.2-20110822.5+kernel-2.6.32-196.el6+kexec-tools-2.6.32-199.el6

How reproducible:
intel-sugarbay-do-01.lab.bos.redhat.com

Steps to Reproduce:
1.Setup Kdump
2.Crash system as CrasherOops
3.
  
Actual results:
WARNING in second kernel

Expected results:
No such WARNING

Additional info:
https://beaker.engineering.redhat.com/recipes/268157

Comment 2 RHEL Product and Program Management 2011-12-20 17:40:26 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 4 RHEL Product and Program Management 2012-05-03 05:43:57 UTC
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 5 Adam Jackson 2013-01-04 17:57:15 UTC
The conditions leading to this error message are significantly different between 6.2 and 6.4.  Please reopen if you can reproduce this with a 6.4 snapshot.


Note You need to log in before you can comment on or make changes to this bug.