Bug 73778 - passwd calls yppasswd when it shouldn't
passwd calls yppasswd when it shouldn't
Status: CLOSED DUPLICATE of bug 43915
Product: Red Hat Linux
Classification: Retired
Component: passwd (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2002-09-10 14:05 EDT by Ed Friedman
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-03-24 14:30:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ed Friedman 2002-09-10 14:05:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-10 i686)

Description of problem:
passwd tries to change the password in the NIS passwd database, even when the
/etc/nsswitch.conf entry for passwd is set to files only.  The end result is
that no users can change their passwords on the local machine if their login
name exists in the NIS database.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Configure a machine with NISDOMAIN set and with passwd in nsswitch.conf set to
files only
2.Create a user on the local machine with a login name identical to an existing
NIS login name
3.Login as that user on the local machine and try to change the password on that
local machine using the passwd command

Actual Results:  It is impossible to change the local password because the
passwd command tries to change the password of the NIS login with the same name

Expected Results:  The local password should have been changed.

Additional info:

In 7.3, the permissions of /usr/bin/yppasswd are now 500, whereas they used to
be 555 in previous RedHat versions.  It appears that someone is trying to
phaseout the yppasswd command by having passwd do an intelligent guess as to
what password should be changed.  However, if that is the case, when
nsswitch.conf has passwd set to files only, then passwd should not be invoking
Comment 1 Tomas Mraz 2005-03-24 14:30:38 EST
Password changing is not affected by /etc/nsswitch.conf but by the nis option of
the pam_unix.so module in the /etc/pam.d/system-auth file. The problem of
changing NIS password when an user is in the local passwd file is fixed in the
current Fedora Core release.

*** This bug has been marked as a duplicate of 43915 ***

Note You need to log in before you can comment on or make changes to this bug.