Bug 737805 - RFE - Maven plugin should use configurable file extension for XLIFF, default to .xlf
RFE - Maven plugin should use configurable file extension for XLIFF, default ...
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Component-Maven, Usability (Show other bugs)
1.4-RC
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Isaac Rooskov
Zanata-QA Mailling List
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-13 03:17 EDT by Sean Flanigan
Modified: 2015-08-06 01:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-23 20:05:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2011-09-13 03:17:49 EDT
Description of problem:
When the Maven plugin looks for XLIFF files, by default it picks up all .xml files, because there is no particular standard for naming XLIFF files.  (The project is expected to specify -Dzanata.includes to narrow down the file list.)  But we could simplify things by checking each XML file for an <xliff> element, and then skip over unsuitable files.

Version-Release number of selected component (if applicable):


How reproducible:
100% if the uploaded project contains XML files which aren't XLIFF.  eg spacewalk project.

Steps to Reproduce:
1. Run mvn zanata:push in a directory tree which contains XLIFF and other XML files.  Don't use the -Dzanata.includes option.
  
Actual results:
Client attempts to upload random .xml files, fails because they aren't XLIFF.

Expected results:
XLIFF files uploaded, other XML files ignored (or warnings generated).

Additional info:
Workaround is to specify '-Dzanata.includes=**/StringResource_en_US.xml' or similar.
Comment 1 Ding-Yi Chen 2012-10-28 23:45:15 EDT
Actually according to OASIS Standard, D.4. XLIFF File Extension

XLIFF documents use the .xlf extension. No other extension is recommended by the specification.
Comment 2 Sean Flanigan 2012-10-29 00:25:27 EDT
That's true.  And the translate toolkit works with XLIFF files (eg for 'pomerge'), but only if they have the extension .xlf.

I think we should change the default file extension to .xlf (for push *and* pull).  Then we won't have to check for XLIFF contents.  

And someone wants to use .xml, they can, but it will be their responsibility to get the 'includes' right.
Comment 3 Michelle Kim 2015-02-23 20:05:10 EST
This should be fixed with the new file mapping rule mechanism.

Note You need to log in before you can comment on or make changes to this bug.