Bug 737852 - Unable to connect to remote hypervisor with xen+ssh
Summary: Unable to connect to remote hypervisor with xen+ssh
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 09:15 UTC by Baptiste AGASSE
Modified: 2011-09-22 15:22 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-22 15:22:47 UTC


Attachments (Terms of Use)

Description Baptiste AGASSE 2011-09-13 09:15:23 UTC
Description of problem:
Add a new connection to remote Xen hypervisor in virt-manager

Version-Release number of selected component (if applicable):
virt-manager.noarch 0.8.7-6.fc15

How reproducible:
Always

Steps to Reproduce:
1. Add new connection to a remote Xen hypervisor using ssh
2. Try to connect to it
  
Actual results:
"Unable to open a connection to the libvirt mamangement daemon
 Libvirt URI is: xen+ssh://user@remotehypervisor.example.org/"

cannot recv data: ssh_askpass: exec(/usr/libexec/openssh/ssh-askpass): No such file or directory

Host key verification failed.

: Connexion ré-initialisée par le correspondant

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 1055, in _try_open
    None], flags)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 107, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: cannot recv data: ssh_askpass: exec(/usr/libexec/openssh/ssh-askpass): No such file or directory

Host key verification failed.

: Connexion ré-initialisée par le correspondant

Expected results:


Additional info:
"ls /usr/libexec/openssh/ssh-askpass" return no such file or directory

Comment 1 Baptiste AGASSE 2011-09-13 09:22:33 UTC
"/usr/libexec/openssh/ssh-askpass" is provided by openssh-askpass package, which is not a dependency of virt-manager. Install this package solve the problem

Comment 2 Cole Robinson 2011-09-22 15:22:47 UTC
Thanks for the report. 

We intentionally don't depend on this package, since it isn't strictly required to use virt-manager. Just for some users who use remote ssh and no keys. So this is NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.