Bug 737858 - Review Request: eclipse-wtp-sourceediting - WTP Source Editing
Summary: Review Request: eclipse-wtp-sourceediting - WTP Source Editing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 09:40 UTC by Vladimir Kostadinov
Modified: 2011-11-26 23:08 UTC (History)
3 users (show)

Fixed In Version: eclipse-wtp-sourceediting-3.3.1-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-03 17:59:06 UTC
akurtako: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Vladimir Kostadinov 2011-09-13 09:40:08 UTC
Spec URL: http://dev.technogamma.biz/eclipse-wtp-sourceediting/eclipse-wtp-sourceediting.spec
SRPM URL: http://dev.technogamma.biz/eclipse-wtp-sourceediting/eclipse-wtp-sourceediting-3.3.0-1.fc15.src.rpm
Description: WTP Source editing tools provide support for editing typical "web" languages and the mixing of them.
XML, XML Schema, XSL, HTML, CSS, DTD, and JSP resources, as well as an XML Perspective.

Comment 1 Alexander Kurtakov 2011-09-13 10:26:45 UTC
MINE :)

Comment 2 Alexander Kurtakov 2011-09-14 19:38:30 UTC
Seems to not be building.

generateScript:
[eclipse.buildScript] Some inter-plug-in dependencies have not been satisfied.
[eclipse.buildScript] Bundle org.eclipse.wst.xsl.debug.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.ui_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsl.launching_[1.0.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsl.core_[1.0.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.ui_[1.0.0,2.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.jsdt.web.core:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.504,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.html.core_[1.1.400,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.validation_[1.2.100,2.0.0).
[eclipse.buildScript] 	Optional plug-in org.eclipse.wst.common.project.facet.core_[1.4.0,2.0.0) is not available.
[eclipse.buildScript] 	Optional plug-in org.eclipse.wst.common.modulecore_[1.1.0,2.0.0) is not available.
[eclipse.buildScript] Bundle org.eclipse.wst.xml.xpath.core:
[eclipse.buildScript] 	Missing required plug-in org.apache.xalan_[2.7.1,2.8.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.xpath2.processor_[2.0.0,3.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_1.1.0.
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsd.core_[1.1.50,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.xpath2.processor_[2.0.0,3.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.xsl.launching:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsl.core_[1.0.0,2.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.xsl.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.300,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.ui_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.apache.xalan_[2.7.1,2.8.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.ui_[1.0.400,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsl.core_1.0.0.
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.validation_[1.1.103,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.xpath.ui_[1.0.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.xpath.core_[1.0.0,2.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.server.core:
[eclipse.buildScript] 	Optional plug-in org.eclipse.wst.common.project.facet.core_[1.1.0,2.0.0) is not available.
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.core_1.2.0.
[eclipse.buildScript] Bundle org.eclipse.wst.jsdt.web.support.jsp:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.jsdt.web.ui_[1.0.200,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.jst.jsp.ui_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.ui_[1.3.0,1.4.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.html.ui_[1.0.500,1.1.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.html.core_[1.1.400,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.jst.jsp.core_[1.2.300,1.3.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.css.core_[1.1.400,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.jsdt.web.core_[1.0.300,2.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.jsdt.web.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.ui_[1.3.0,1.4.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.ui_[1.1.100,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.jsdt.web.core_[1.0.300,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.css.core_[1.1.400,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.uriresolver_[1.1.300,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.html.ui_[1.0.500,1.1.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.html.core_[1.1.400,1.2.0).
[eclipse.buildScript] Bundle org.eclipse.wst.xsl.jaxp.launching:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsl.launching_[1.0.0,2.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.standard.schemas:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.0,2.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.xml.xpath2.processor:
[eclipse.buildScript] 	Missing required plug-in java_cup.runtime_0.10.0.
[eclipse.buildScript] Bundle org.eclipse.wst.xsl.core:
[eclipse.buildScript] 	Missing required plug-in org.apache.xalan_[2.7.1,2.8.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.uriresolver_[1.1.301,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.300,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.300,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.validation_[1.1.103,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.xpath.core_[1.0.0,2.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.web.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.frameworks_[1.2.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.frameworks.ui_[1.2.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.web_[1.1.0,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.modulecore_[1.2.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.project.facet.ui_[1.3.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.project.facet.core_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.server.ui_[1.0.102,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.environment_[1.0.100,1.1.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.css.ui_[1.0.0,1.1.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.html.ui_[1.0.0,1.1.0).
[eclipse.buildScript] Bundle org.eclipse.wst.xml.xpath.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.ui_[1.0.101,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.ui_[1.0.101,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.uriresolver_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.xpath.core_[1.2.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.apache.xalan_2.7.1.
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.xpath2.processor_[2.0.0,3.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.xpath2.wtptypes_[2.0.0,3.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.xsd.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.uriresolver_[1.1.0,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.ui_[1.2.0,1.4.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.300,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.core_[1.1.0,1.3.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.300,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.ui_[1.0.400,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.ui_[1.1.0,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.validation_[1.2.0,1.3.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsd.core_[1.1.300,1.2.0).
[eclipse.buildScript] Bundle org.eclipse.wst.server.http.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.server.core_[1.0.204,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.server.ui_[1.0.103,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.server.http.core_[1.0.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.project.facet.ui_[1.2.0,2.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.xsd.core:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.uriresolver_[1.1.0,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.0,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.validation_[1.2.0,1.3.0).
[eclipse.buildScript] Bundle org.eclipse.wst.html.core:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.uriresolver_[1.1.301,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.css.core_[1.1.400,1.2.0).
[eclipse.buildScript] 	Optional plug-in org.eclipse.wst.common.modulecore_[1.2.0,2.0.0) is not available.
[eclipse.buildScript] Bundle org.eclipse.wst.server.preview.adapter:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.server.core_[1.0.204,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.server.ui_[1.0.103,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.project.facet.ui_[1.2.0,2.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.server.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.server.core_[1.0.103,2.0.0).
[eclipse.buildScript] 	Optional plug-in org.eclipse.wst.common.project.facet.ui_[1.1.0,2.0.0) is not available.
[eclipse.buildScript] Bundle org.eclipse.wst.xml.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.ui_[1.2.0,1.4.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.uriresolver_[1.1.301,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.ui_[1.1.400,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.validation_[1.2.100,1.3.0).
[eclipse.buildScript] Bundle org.eclipse.wst.xml.xpath2.wtptypes:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.xpath2.processor_[2.0.0,3.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsd.core_[1.1.600,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_1.1.600.
[eclipse.buildScript] Bundle org.eclipse.wst.xsl.xalan:
[eclipse.buildScript] 	Missing required plug-in org.apache.xalan_[2.7.0,2.8.0).
[eclipse.buildScript] Bundle org.eclipse.wst.dtd.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.ui_[1.1.301,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.dtd.core_[1.1.200,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.300,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.ui_[1.2.0,1.4.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.300,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.ui_[1.0.400,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.uriresolver_[1.1.301,1.2.0).
[eclipse.buildScript] Bundle org.eclipse.wst.xsl.jaxp.debug.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsl.debug.ui_[1.0.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsl.launching_[1.0.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsl.jaxp.launching_[1.0.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.ui_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsl.ui_[1.0.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.300,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.300,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.ui_[1.0.400,2.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.xsl.exslt.core:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.uriresolver_[1.1.0,2.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.html.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.ui_[1.2.0,1.4.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.ui_[1.1.100,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.css.ui_[1.0.500,1.1.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.css.core_[1.1.400,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.html.core_[1.1.400,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.validation_[1.2.100,1.3.0).
[eclipse.buildScript] 	Optional plug-in org.eclipse.wst.common.project.facet.core_[1.4.0,2.0.0) is not available.
[eclipse.buildScript] 	Optional plug-in org.eclipse.wst.common.modulecore_[1.2.0,2.0.0) is not available.
[eclipse.buildScript] Bundle org.eclipse.wst.css.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.ui_[1.1.100,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.ui_[1.2.0,1.4.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.css.core_[1.1.300,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.html.core_[1.1.400,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Optional plug-in org.eclipse.wst.common.project.facet.core_[1.4.0,2.0.0) is not available.
[eclipse.buildScript] 	Optional plug-in org.eclipse.wst.common.modulecore_[1.2.0,2.0.0) is not available.
[eclipse.buildScript] Bundle org.eclipse.wst.sse.core:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.uriresolver_[1.1.301,1.2.0).
[eclipse.buildScript] 	Optional plug-in org.eclipse.wst.validation_[1.2.100,2.0.0) is not available.
[eclipse.buildScript] Bundle org.eclipse.wst.dtd.core:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.uriresolver_[1.1.301,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.300,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.300,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.validation_[1.2.0,1.3.0).
[eclipse.buildScript] Bundle org.eclipse.wst.xsl.exslt.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsl.ui_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsl.core_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.ui_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xsl.exslt.core_[1.0.0,2.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.sse.ui:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.validation_[1.2.100,1.3.0).
[eclipse.buildScript] Bundle org.eclipse.wst.xml.core:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.uriresolver_[1.1.301,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Optional plug-in org.eclipse.jem.util_[2.0.200,3.0.0) is not available.
[eclipse.buildScript] 	Optional plug-in org.eclipse.wst.validation_[1.2.100,1.3.0) is not available.
[eclipse.buildScript] 	Optional plug-in org.eclipse.wst.common.emf_[1.1.300,1.3.0) is not available.
[eclipse.buildScript] 	Optional plug-in org.eclipse.wst.common.emfworkbench.integration_[1.1.300,1.3.0) is not available.
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.core_[1.1.201,1.3.0).
[eclipse.buildScript] Bundle org.eclipse.wst.web:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.frameworks_[1.2.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.validation_[1.2.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.emfworkbench.integration_[1.2.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.server.core_[1.0.102,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.jem.util_[2.0.0,3.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.modulecore_[1.2.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.project.facet.core_[1.1.0,2.0.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.common.environment_[1.0.100,1.1.0).
[eclipse.buildScript] Bundle org.eclipse.wst.server.http.core:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.server.core_[1.0.204,2.0.0).
[eclipse.buildScript] Bundle org.eclipse.wst.css.core:
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.xml.core_[1.1.500,1.2.0).
[eclipse.buildScript] 	Missing required plug-in org.eclipse.wst.sse.core_[1.1.500,1.2.0).

BUILD FAILED
/usr/lib/eclipse/dropins/sdk/plugins/org.eclipse.pde.build_3.7.0.v20110512-1320/scripts/build.xml:35: The following error occurred while executing this line:
/usr/lib/eclipse/dropins/sdk/plugins/org.eclipse.pde.build_3.7.0.v20110512-1320/scripts/build.xml:91: The following error occurred while executing this line:
/usr/lib/eclipse/dropins/sdk/plugins/org.eclipse.pde.build_3.7.0.v20110512-1320/templates/package-build/customTargets.xml:19: The following error occurred while executing this line:
/usr/lib/eclipse/dropins/sdk/plugins/org.eclipse.pde.build_3.7.0.v20110512-1320/scripts/genericTargets.xml:111: Unable to find feature: org.eclipse.wst.common_core.feature.

xalan-j2 is not an OSGi bundle so I'm not sure how did you build it. Same for java_cup.

Comment 3 Vladimir Kostadinov 2011-09-15 17:39:06 UTC
Spec URL:
http://dev.technogamma.biz/eclipse-wtp-sourceediting/eclipse-wtp-sourceediting.spec
SRPM URL:
http://dev.technogamma.biz/eclipse-wtp-sourceediting/eclipse-wtp-sourceediting-3.3.0-2.fc15.src.rpm

Fixed PDE Build Eclipse plugin dependencies. Strangely enough could not reproduce build failure using my build platform. Tested with Koji scratch build.

Comment 4 Alexander Kurtakov 2011-09-19 08:48:07 UTC
Package Review
==============

Key:
- = N/A
x = Check
! = Problem
? = Not evaluated

=== REQUIRED ITEMS ===
[!]  Rpmlint output:
eclipse-wtp-sourceediting.noarch: E: description-line-too-long C WTP Source editing tools provide support for editing typical "web" languages and the mixing of them.
eclipse-wtp-sourceediting.noarch: E: description-line-too-long C XML, XML Schema, XSL, HTML, CSS, DTD, and JSP resources, as well as an XML Perspective.
Please fix.
eclipse-wtp-sourceediting.noarch: W: dangling-symlink /usr/share/eclipse/dropins/wtp-sourceediting/eclipse/plugins/xml-commons-apis.jar /usr/share/java/xml-commons-apis.jar
Fine.
eclipse-wtp-sourceediting.noarch: W: spurious-executable-perm /usr/share/doc/eclipse-wtp-sourceediting-3.3.0/about.html
Please fix.
eclipse-wtp-sourceediting.noarch: W: dangling-symlink /usr/share/eclipse/dropins/wtp-sourceediting/eclipse/plugins/rhino.jar /usr/share/java/rhino.jar
eclipse-wtp-sourceediting.noarch: W: dangling-symlink /usr/share/eclipse/dropins/wtp-sourceediting/eclipse/plugins/xml-resolver.jar /usr/share/java/xml-resolver.jar
eclipse-wtp-sourceediting.noarch: W: dangling-symlink /usr/share/eclipse/dropins/wtp-sourceediting/eclipse/plugins/xerces-j2.jar /usr/share/java/xerces-j2.jar
eclipse-wtp-sourceediting.noarch: W: dangling-symlink /usr/share/eclipse/dropins/wtp-sourceediting/eclipse/plugins/xalan-j2-serializer.jar /usr/share/java/xalan-j2-serializer.jar
Fine.
[x]  Package is named according to the Package Naming Guidelines[1].
[x]  Spec file name must match the base package name, in the format %{name}.spec.
[x]  Package meets the Packaging Guidelines[2].
[x]  Package successfully compiles and builds into binary rpms.
[x]  Buildroot definition is not present
[x]  Package is licensed with an open-source compatible license and meets other legal requirements as defined in the legal section of Packaging Guidelines[3,4].
[x]  License field in the package spec file matches the actual license.
License type: EPL
[-]  If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package is included in %doc.
[-]  All independent sub-packages have license of their own
[x]  Spec file is legible and written in American English.
[-]  Sources used to build the package matches the upstream source, as provided in the spec URL.
[x]  All build dependencies are listed in BuildRequires, except for any that are listed in the exceptions section of Packaging Guidelines[5].
[x]  Package must own all directories that it creates.
[x]  Package requires other packages for directories it uses.
[x]  Package does not contain duplicates in %files.
[x]  File sections do not contain %defattr(-,root,root,-) unless changed with good reason
[!]  Permissions on files are set properly.
[x]  Package does NOT have a %clean section which contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT). (not needed anymore)
[x]  Package consistently uses macros (no %{buildroot} and $RPM_BUILD_ROOT mixing)
[x]  Package contains code, or permissable content.
[-]  Fully versioned dependency in subpackages, if present.
[-]  Package contains a properly installed %{name}.desktop file if it is a GUI application.
[x]  Package does not own files or directories owned by other packages.
[-]  Javadoc documentation files are generated and included in -javadoc subpackage
[-]  Javadocs are placed in %{_javadocdir}/%{name} (no -%{version} symlinks)
[x]  Packages have proper BuildRequires/Requires on jpackage-utils
[-]  Javadoc subpackages have Require: jpackage-utils
[x]  Package uses %global not %define
[x]  If package uses tarball from VCS include comment how to re-create that tarball (svn export URL, git clone URL, ...)
[x]  If source tarball includes bundled jar/class files these need to be removed prior to building
[x]  All filenames in rpm packages must be valid UTF-8.
[-]  Jar files are installed to %{_javadir}/%{name}.jar (see [6] for details)
[-]  If package contains pom.xml files install it (including depmaps) even when building with ant

=== Other suggestions ===
[x]  If possible use upstream build method (maven/ant/javac)
[x]  Avoid having BuildRequires on exact NVR unless necessary
[x]  Package has BuildArch: noarch (if possible)
[x]  Latest version is packaged.

Issues:
* fix line lengths
* fix about.xml permissions

Comment 5 Vladimir Kostadinov 2011-09-19 09:48:49 UTC
Spec URL:
http://dev.technogamma.biz/eclipse-wtp-sourceediting/eclipse-wtp-sourceediting.spec
SRPM URL:
http://dev.technogamma.biz/eclipse-wtp-sourceediting/eclipse-wtp-sourceediting-3.3.0-3.fc15.src.rpm

- Fixed description length
- Fixed doc file permissions in fetch-wtp-sourceediting.sh

Comment 6 Alexander Kurtakov 2011-09-19 09:50:27 UTC
Thanks,

APPROVED

Comment 7 Vladimir Kostadinov 2011-09-19 10:09:06 UTC
New Package SCM Request
=======================
Package Name: eclipse-wtp-sourceediting
Short Description: WTP Source editing tools provide support for editing typical "web" languages and the mixing of them.
Owners: vladimirk
Branches: f16
InitialCC: akurtakov

Comment 8 Gwyn Ciesla 2011-09-19 10:16:52 UTC
Git done (by process-git-requests).

Comment 9 Fedora Update System 2011-09-19 17:21:24 UTC
eclipse-wtp-sourceediting-3.3.0-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/eclipse-wtp-sourceediting-3.3.0-3.fc16

Comment 10 Fedora Update System 2011-09-19 18:30:45 UTC
eclipse-wtp-sourceediting-3.3.0-3.fc16 has been pushed to the Fedora 16 testing repository.

Comment 11 Fedora Update System 2011-10-03 17:59:00 UTC
eclipse-wtp-sourceediting-3.3.0-3.fc16 has been pushed to the Fedora 16 stable repository.

Comment 12 Fedora Update System 2011-11-17 10:15:56 UTC
eclipse-wtp-sourceediting-3.3.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/eclipse-wtp-sourceediting-3.3.1-1.fc16

Comment 13 Fedora Update System 2011-11-26 23:08:40 UTC
eclipse-wtp-sourceediting-3.3.1-1.fc16 has been pushed to the Fedora 16 stable repository.


Note You need to log in before you can comment on or make changes to this bug.